aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index ac4ec2644..fa0b8ba49 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -67,9 +67,12 @@ extra_install:
done
install -d $(DESTDIR)$(PREFIX)/lib/ikiwiki/plugins
- for file in `find plugins -maxdepth 1 -type f ! -wholename plugins/.\* | grep -v demo`; do \
- cp -a $$file $(DESTDIR)$(PREFIX)/lib/ikiwiki/plugins; \
- done \
+ for file in `find plugins -maxdepth 1 -type f ! -wholename plugins/.\* ! -name \*demo\* -name \*.py`; do \
+ install -m 644 $$file $(DESTDIR)$(PREFIX)/lib/ikiwiki/plugins; \
+ done
+ for file in `find plugins -maxdepth 1 -type f ! -wholename plugins/.\* ! -name \*demo\* ! -name \*.py`; do \
+ install -m 755 $$file $(DESTDIR)$(PREFIX)/lib/ikiwiki/plugins; \
+ done
install -d $(DESTDIR)$(PREFIX)/share/man/man1
install -m 644 ikiwiki.man $(DESTDIR)$(PREFIX)/share/man/man1/ikiwiki.1