aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-08-21 16:21:40 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-08-21 16:21:40 -0400
commitdec9b4e2c9eab4fd5cbd661eb475d96e9e5ca8c0 (patch)
tree0be610842022f8de519c14a044ec5eca6e4a0283 /Makefile.PL
parentb12f29e4562e73e52c1a923c3c3b743b9bbc4ce2 (diff)
downloadikiwiki-dec9b4e2c9eab4fd5cbd661eb475d96e9e5ca8c0.tar
ikiwiki-dec9b4e2c9eab4fd5cbd661eb475d96e9e5ca8c0.tar.gz
Avoid using cp -a (again). (HenrikBrixAndersen)
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index ac4ec2644..fa0b8ba49 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -67,9 +67,12 @@ extra_install:
done
install -d $(DESTDIR)$(PREFIX)/lib/ikiwiki/plugins
- for file in `find plugins -maxdepth 1 -type f ! -wholename plugins/.\* | grep -v demo`; do \
- cp -a $$file $(DESTDIR)$(PREFIX)/lib/ikiwiki/plugins; \
- done \
+ for file in `find plugins -maxdepth 1 -type f ! -wholename plugins/.\* ! -name \*demo\* -name \*.py`; do \
+ install -m 644 $$file $(DESTDIR)$(PREFIX)/lib/ikiwiki/plugins; \
+ done
+ for file in `find plugins -maxdepth 1 -type f ! -wholename plugins/.\* ! -name \*demo\* ! -name \*.py`; do \
+ install -m 755 $$file $(DESTDIR)$(PREFIX)/lib/ikiwiki/plugins; \
+ done
install -d $(DESTDIR)$(PREFIX)/share/man/man1
install -m 644 ikiwiki.man $(DESTDIR)$(PREFIX)/share/man/man1/ikiwiki.1