aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL29
1 files changed, 29 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100755
index 000000000..1e9d374a4
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,29 @@
+#!/usr/bin/perl
+use warnings;
+use strict;
+use ExtUtils::MakeMaker;
+
+# Add a few more targets.
+sub MY::postamble {
+q{
+all:: extra_build
+clean:: extra_clean
+install:: extra_install
+pure_install:: extra_install
+
+extra_build:
+ ./ikiwiki doc templates html --wikiname="ikiwiki" --verbose \
+ --nosvn --exclude=/discussion
+
+extra_clean:
+ rm -rf html
+ rm -rf doc/.ikiwiki
+
+extra_install:
+}
+}
+
+WriteMakefile(
+ 'NAME' => 'IkiWiki',
+ 'EXE_FILES' => ['ikiwiki'],
+);