aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2006-03-15 03:24:34 +0000
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2006-03-15 03:24:34 +0000
commit0a52e8fd82d80bdd1290f49c3187d3f72db39c75 (patch)
treea7ebf87944648b6837e837bbd7be9c472be38bcd /Makefile.PL
parent2d1989983e8978f024bbb8fdd0e68445913c0a8e (diff)
downloadikiwiki-0a52e8fd82d80bdd1290f49c3187d3f72db39c75.tar
ikiwiki-0a52e8fd82d80bdd1290f49c3187d3f72db39c75.tar.gz
config files now based on perl modules
add MakeMaker foo for module
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL29
1 files changed, 29 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100755
index 000000000..1e9d374a4
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,29 @@
+#!/usr/bin/perl
+use warnings;
+use strict;
+use ExtUtils::MakeMaker;
+
+# Add a few more targets.
+sub MY::postamble {
+q{
+all:: extra_build
+clean:: extra_clean
+install:: extra_install
+pure_install:: extra_install
+
+extra_build:
+ ./ikiwiki doc templates html --wikiname="ikiwiki" --verbose \
+ --nosvn --exclude=/discussion
+
+extra_clean:
+ rm -rf html
+ rm -rf doc/.ikiwiki
+
+extra_install:
+}
+}
+
+WriteMakefile(
+ 'NAME' => 'IkiWiki',
+ 'EXE_FILES' => ['ikiwiki'],
+);