aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index e1a953f8f..b19636c60 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -154,6 +154,13 @@ extra_install: underlay_install
-install -m 0644 wikilist $(DESTDIR)/etc/ikiwiki
-install -m 0644 auto.setup $(DESTDIR)/etc/ikiwiki
-install -m 0644 auto-blog.setup $(DESTDIR)/etc/ikiwiki
+
+# The git/hg plugins want to chdir; so does Devel::Cover. Skip those tests
+# to stop them hurting each other.
+coverage:
+ cover -delete
+ $(MAKE) test PERL5OPT=-MDevel::Cover PERL5LIB=. TEST_FILES="$(filter-out t/git.t t/mercurial.t,$(wildcard t/*.t))"
+ cover
}
}