aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2011-11-04 18:18:33 +0000
committerSimon McVittie <smcv@debian.org>2011-11-09 22:49:36 +0000
commit7179ddce82944702f460bd931448de08c341633d (patch)
treeaa496d6fc3d3bbbba160240d5378c5e302496bfb /Makefile.PL
parent4a1a49052669eb558e69923ee91d5b73b15594fe (diff)
downloadikiwiki-7179ddce82944702f460bd931448de08c341633d.tar
ikiwiki-7179ddce82944702f460bd931448de08c341633d.tar.gz
Add test coverage analysis (make coverage)
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index e1a953f8f..b19636c60 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -154,6 +154,13 @@ extra_install: underlay_install
-install -m 0644 wikilist $(DESTDIR)/etc/ikiwiki
-install -m 0644 auto.setup $(DESTDIR)/etc/ikiwiki
-install -m 0644 auto-blog.setup $(DESTDIR)/etc/ikiwiki
+
+# The git/hg plugins want to chdir; so does Devel::Cover. Skip those tests
+# to stop them hurting each other.
+coverage:
+ cover -delete
+ $(MAKE) test PERL5OPT=-MDevel::Cover PERL5LIB=. TEST_FILES="$(filter-out t/git.t t/mercurial.t,$(wildcard t/*.t))"
+ cover
}
}