aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2006-03-15 04:05:53 +0000
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2006-03-15 04:05:53 +0000
commit1186094987d8ddb725cf4d69fa357741117d7c11 (patch)
treef1ad1b7ccd2d6956867410e293d37cdb0f101414 /debian/rules
parent0a52e8fd82d80bdd1290f49c3187d3f72db39c75 (diff)
downloadikiwiki-1186094987d8ddb725cf4d69fa357741117d7c11.tar
ikiwiki-1186094987d8ddb725cf4d69fa357741117d7c11.tar.gz
debianise
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules38
1 files changed, 38 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 000000000..7a0f8868f
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,38 @@
+#!/usr/bin/make -f
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ perl Makefile.PL
+ $(MAKE)
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+ perl Makefile.PL
+ -$(MAKE) realclean
+ dh_clean
+
+binary-arch: build
+
+binary-indep: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ $(MAKE) pure_install INSTALLDIRS=vendor \
+ PREFIX=$(shell pwd)/debian/ikiwiki/$(shell perl -MConfig -e 'print $$Config{prefix}')
+ dh_installdocs html
+ dh_installexamples
+ dh_installchangelogs
+ dh_compress
+ dh_fixperms
+ dh_perl
+ dh_installdeb
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary