aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2006-03-15 04:05:53 +0000
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2006-03-15 04:05:53 +0000
commit1186094987d8ddb725cf4d69fa357741117d7c11 (patch)
treef1ad1b7ccd2d6956867410e293d37cdb0f101414 /debian
parent0a52e8fd82d80bdd1290f49c3187d3f72db39c75 (diff)
downloadikiwiki-1186094987d8ddb725cf4d69fa357741117d7c11.tar
ikiwiki-1186094987d8ddb725cf4d69fa357741117d7c11.tar.gz
debianise
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control21
-rw-r--r--debian/copyright5
-rwxr-xr-xdebian/rules38
5 files changed, 70 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 000000000..4cc350333
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+ikiwiki (0.1) unstable; urgency=low
+
+ * Initial release.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 14 Mar 2006 22:44:16 -0500
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 000000000..7ed6ff82d
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 000000000..4abae5dbf
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,21 @@
+Source: ikiwiki
+Section: web
+Priority: optional
+Build-Depends: debhelper (>= 5), dpkg-dev (>= 1.9.0), markdown, libhtml-template-perl
+Maintainer: Joey Hess <joeyh@debian.org>
+Standards-Version: 3.6.2
+
+Package: ikiwiki
+Architecture: all
+Depends: ${perl:Depends}, markdown, libhtml-template-perl, libcgi-formbuilder-perl, libtime-duration-perl, libcgi-session-perl, libmail-sendmail-perl, gcc | c-compiler
+Recommends: subversion
+Suggests: viewcvs
+Description: a wiki compiler
+ ikiwiki converts a directory full of wiki pages into html pages suitable
+ for publishing on a website. Unlike many wikis, ikiwiki does not have its
+ own means of storing page history or its own markup language. Instead it
+ uses subversion and markdown.
+ .
+ ikiwiki implements most of the other standard features of a wiki, including
+ web-based page editing, user registration and logins, and a RecentChanges
+ page.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 000000000..0992a2a2d
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,5 @@
+ikiwiki is copyright 2006 by Joey Hess <joey@kitenet.net>. It is licensed
+under the terms of the GPL.
+
+On Debian systems, the complete text of the GPL can be found in
+/usr/share/common-licenses/GPL.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 000000000..7a0f8868f
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,38 @@
+#!/usr/bin/make -f
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ perl Makefile.PL
+ $(MAKE)
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+ perl Makefile.PL
+ -$(MAKE) realclean
+ dh_clean
+
+binary-arch: build
+
+binary-indep: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ $(MAKE) pure_install INSTALLDIRS=vendor \
+ PREFIX=$(shell pwd)/debian/ikiwiki/$(shell perl -MConfig -e 'print $$Config{prefix}')
+ dh_installdocs html
+ dh_installexamples
+ dh_installchangelogs
+ dh_compress
+ dh_fixperms
+ dh_perl
+ dh_installdeb
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary