aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2007-02-21 00:36:57 +0000
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2007-02-21 00:36:57 +0000
commitfe350344ca56555ed89b6919e39933b08944c452 (patch)
treecc1da921f9b3a1fd69edb7be6be6aba889958ac2 /Makefile.PL
parenta42a478a9eb21029a74e95a1c732fc72ce5142a9 (diff)
downloadikiwiki-fe350344ca56555ed89b6919e39933b08944c452.tar
ikiwiki-fe350344ca56555ed89b6919e39933b08944c452.tar.gz
PERL5LIB won't work when using the taint flag, and use lib "." is removed
since ikiwiki.out is run now. So switch to using -I.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 39961f79a..0039d1bc0 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -23,10 +23,12 @@ PROBABLE_INST_LIB=$(shell \\
fi \\
)
+tflag=$(shell if [ ! "$$NOTAINT" ]; then printf -- "-T"; fi)
+
extra_build:
./pm_filter $(PREFIX) $(VER) $(PROBABLE_INST_LIB) < ikiwiki.in > ikiwiki.out
chmod +x ikiwiki.out
- PERL5LIB=.:${PERL5LIB} LANG=C ./ikiwiki.out doc html --templatedir=templates \
+ LANG=C perl -I. $(tflag) ikiwiki.out doc html --templatedir=templates \
--underlaydir=basewiki \
--wikiname="ikiwiki" --verbose --no-rcs \
--exclude=/discussion --no-discussion --userdir=users \