aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2007-05-10 18:59:02 +0000
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2007-05-10 18:59:02 +0000
commitf23ebaad2eae04263fe195a10712cb633c32dee9 (patch)
tree6e47bccc6bd6d9b588ff5ab46c438ad07c89e8a6 /Makefile.PL
parentb15f37e9e9e617e049207eca04652a8794e9b1de (diff)
downloadikiwiki-f23ebaad2eae04263fe195a10712cb633c32dee9.tar
ikiwiki-f23ebaad2eae04263fe195a10712cb633c32dee9.tar.gz
* Apply patch from Pawel to avoid using -L in Makefile as it's not available
in older finds.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 73c4950cb..5514a98ce 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -47,9 +47,9 @@ extra_clean:
extra_install:
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki
- for dir in `find -L basewiki templates -type d ! -regex '.*\.svn.*'`; do \
+ for dir in `find basewiki templates -follow -type d ! -regex '.*\.svn.*'`; do \
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
- for file in `find -L $$dir -maxdepth 1 -type f`; do \
+ for file in `find $$dir -follow -maxdepth 1 -type f`; do \
install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
done; \
done