aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-02-04 21:08:03 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-02-04 21:08:03 -0500
commitcc055d2c95d7292ee6eca47801e05f3c238fed45 (patch)
treed28ef99a11d4725b3b63b42ec92231491dd311b6 /Makefile.PL
parent6655fbb991051d2af8965bfcc0d899a25b7e478f (diff)
downloadikiwiki-cc055d2c95d7292ee6eca47801e05f3c238fed45.tar
ikiwiki-cc055d2c95d7292ee6eca47801e05f3c238fed45.tar.gz
makefile portability patch
from Thomas Keller, who explains: 1) find -wholename is not available on BSD / OSX (a nice rant about this issue is here: http://fuhm.livejournal.com/1848.html) 2) cp -a is not available on BSD / OSX, there is an alternative install call, but it might be cool to just shut up cp complaining about it... ;) 3) Two find calls have been missing the path argument.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.PL b/Makefile.PL
index d29804cca..5c450e619 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -57,7 +57,7 @@ extra_install:
for dir in `cd underlays && find . -follow -type d ! -regex '.*\.svn.*'`; do \
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
for file in `find underlays/$$dir -follow -maxdepth 1 -type f`; do \
- cp -aL $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir || \
+ cp -aL $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir 2>/dev/null || \
install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
done; \
done
@@ -71,11 +71,11 @@ extra_install:
done
# Install example sites.
- for dir in `cd doc/examples; find -type d ! -regex '.*\.svn.*'`; do \
+ for dir in `cd doc/examples; find . -type d ! -regex '.*\.svn.*'`; do \
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/examples/$$dir; \
done
- for file in `cd doc/examples; find -type f ! -regex '.*\.svn.*'`; do \
- cp -aL doc/examples/$$file $(DESTDIR)$(PREFIX)/share/ikiwiki/examples/$$file || \
+ for file in `cd doc/examples; find . -type f ! -regex '.*\.svn.*'`; do \
+ cp -aL doc/examples/$$file $(DESTDIR)$(PREFIX)/share/ikiwiki/examples/$$file 2>/dev/null || \
install -m 644 doc/examples/$$file $(DESTDIR)$(PREFIX)/share/ikiwiki/examples/$$file; \
done
@@ -87,10 +87,10 @@ extra_install:
done
install -d $(DESTDIR)$(PREFIX)/lib/ikiwiki/plugins
- for file in `find plugins -maxdepth 1 -type f ! -wholename plugins/.\* ! -name \*demo\* -name \*.py`; do \
+ for file in `find plugins -maxdepth 1 -type f ! -path plugins/.\* ! -name \*demo\* -name \*.py`; do \
install -m 644 $$file $(DESTDIR)$(PREFIX)/lib/ikiwiki/plugins; \
done
- for file in `find plugins -maxdepth 1 -type f ! -wholename plugins/.\* ! -name \*demo\* ! -name \*.py ! -name \*.pyc`; do \
+ for file in `find plugins -maxdepth 1 -type f ! -path plugins/.\* ! -name \*demo\* ! -name \*.py ! -name \*.pyc`; do \
install -m 755 $$file $(DESTDIR)$(PREFIX)/lib/ikiwiki/plugins; \
done