aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-09-11 18:46:32 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-09-11 18:46:32 -0400
commitbc7381c4f9f76cbef6bef27cc382a8246b58a4f7 (patch)
tree30d1f252573f704eb27a09c48b96f2f0b0dda5ce /Makefile.PL
parent9921a4a8a1a696ce69acce5e14943f0149d926ff (diff)
downloadikiwiki-bc7381c4f9f76cbef6bef27cc382a8246b58a4f7.tar
ikiwiki-bc7381c4f9f76cbef6bef27cc382a8246b58a4f7.tar.gz
listdirectives: Enable use of the directives underlay.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 78e659fe6..95e574c66 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -57,6 +57,15 @@ extra_install:
install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
done; \
done
+
+ # The directive docs become their own special underlay.
+ install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/directives/ikiwiki/directive
+ for file in doc/ikiwiki/directive/*; do \
+ if [ -f "$$file" ]; then \
+ install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/directives/ikiwiki/directive; \
+ fi \
+ done
+
for dir in `find templates -follow -type d ! -regex '.*\.svn.*'`; do \
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
for file in `find $$dir -follow -maxdepth 1 -type f`; do \