aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2015-03-01 16:14:32 +0000
committerSimon McVittie <smcv@debian.org>2015-03-01 16:15:01 +0000
commita1fda0b516cc4e85b7304838949df8fbe0044cf3 (patch)
treecc1a5cade5f89ad2386cd39e8f1e319875c61b8f /Makefile.PL
parent0700b26b58bac8670b21afb502540c61deac3065 (diff)
downloadikiwiki-a1fda0b516cc4e85b7304838949df8fbe0044cf3.tar
ikiwiki-a1fda0b516cc4e85b7304838949df8fbe0044cf3.tar.gz
Standardize on --long-option instead of -long-option
[[forum/refresh_and_setup]] indicates some confusion between --setup and -setup. Both work, but it's clearer if we stick to one in documentation and code. A 2012 commit to [[plugins/theme]] claims that "-setup" is required and "--setup" won't work, but I cannot find any evidence in ikiwiki's source code that this has ever been the case.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 5b0eb7471..bee9dfa11 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -44,7 +44,7 @@ PROBABLE_INST_LIB=$(shell \\
chmod +x $@
ikiwiki.setup:
- HOME=/home/me $(PERL) -Iblib/lib $(extramodules) $(tflag) ikiwiki.in -dumpsetup ikiwiki.setup
+ HOME=/home/me $(PERL) -Iblib/lib $(extramodules) $(tflag) ikiwiki.in --dumpsetup ikiwiki.setup
extra_build: perl_shebangs $(outprogs) ikiwiki.setup docwiki sysconfdir
./mdwn2man ikiwiki 1 doc/usage.mdwn > ikiwiki.man
@@ -59,7 +59,7 @@ extra_build: perl_shebangs $(outprogs) ikiwiki.setup docwiki sysconfdir
rm -f ikiwiki.spec.bkp
docwiki:
- $(PERL) -Iblib/lib $(extramodules) $(tflag) ikiwiki.in -setup docwiki.setup -refresh
+ $(PERL) -Iblib/lib $(extramodules) $(tflag) ikiwiki.in --setup docwiki.setup --refresh
perl_shebangs:
ifneq "$(PERL)" "/usr/bin/perl"
@@ -83,7 +83,7 @@ sysconfdir:
$(PERL) -pi -e "s|\"/etc/ikiwiki|\"$(SYSCONFDIR)|g" $(sysconfdir_scripts)
extra_clean: perl_shebangs_clean
- $(PERL) -Iblib/lib $(extramodules) $(tflag) ikiwiki.in -setup docwiki.setup -clean
+ $(PERL) -Iblib/lib $(extramodules) $(tflag) ikiwiki.in --setup docwiki.setup --clean
rm -f *.man $(outprogs) ikiwiki.setup plugins/*.pyc
$(MAKE) -C po clean