aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2006-08-08 14:55:14 +0000
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2006-08-08 14:55:14 +0000
commit9dee2ec20e840a05445646f2e4b1c7137700a97e (patch)
tree6a224e0223d644e6abffa7716f5d39c84c01c734 /Makefile.PL
parentd2b0ac88a7c0c0b60a5c6e42e0024dc0b1ad3b87 (diff)
downloadikiwiki-9dee2ec20e840a05445646f2e4b1c7137700a97e.tar
ikiwiki-9dee2ec20e840a05445646f2e4b1c7137700a97e.tar.gz
* Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
case-sensative filesystems like OSX.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 303116faa..7b61acc61 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -12,7 +12,7 @@ install:: extra_install
pure_install:: extra_install
extra_build:
- ./ikiwiki doc html --templatedir=templates --underlaydir=basewiki \
+ ./ikiwiki.pl doc html --templatedir=templates --underlaydir=basewiki \
--wikiname="ikiwiki" --verbose --no-rcs \
--exclude=/discussion --no-discussion \
--plugin=brokenlinks --plugin=pagecount \
@@ -50,5 +50,5 @@ extra_install:
WriteMakefile(
'NAME' => 'IkiWiki',
'PM_FILTER' => 'grep -v "removed by Makefile"',
- 'EXE_FILES' => ['ikiwiki'],
+ 'EXE_FILES' => ['ikiwiki.pl'],
);