aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2007-08-28 01:59:01 +0000
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2007-08-28 01:59:01 +0000
commit9c5f4761d8bf785ca98d5fda66fbbe9dbe11897c (patch)
tree6e2c8fab91dd051a7acc2cf0ab7c71fc58f6c278 /Makefile.PL
parent21c4bd8444480d6038d217fa2892d13ecce500ff (diff)
downloadikiwiki-9c5f4761d8bf785ca98d5fda66fbbe9dbe11897c.tar
ikiwiki-9c5f4761d8bf785ca98d5fda66fbbe9dbe11897c.tar.gz
* Support for looking in multiple directories for underlay files.
* Plugins can add new directories to the search path with the add_underlay function. * Split out smiley underlay files into a separate underlay, so if the plugin isn't used, the wiki isn't bloated with all those files.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index aba4239d8..1add3cf1c 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -32,7 +32,7 @@ ikiwiki.out: ikiwiki.in
extra_build: ikiwiki.out
LANG= perl -I. $(extramodules) $(tflag) ikiwiki.out doc html --templatedir=templates \
- --underlaydir=basewiki --nousedirs\
+ --underlaydir=underlays/basewiki --nousedirs\
--wikiname="ikiwiki" --verbose \
--exclude=/discussion --no-discussion --userdir=users \
--plugin=goodstuff \
@@ -49,7 +49,13 @@ extra_clean:
extra_install:
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki
- for dir in `find basewiki templates -follow -type d ! -regex '.*\.svn.*'`; do \
+ for dir in `cd underlays && find . -follow -type d ! -regex '.*\.svn.*'`; do \
+ install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
+ for file in `find underlays/$$dir -follow -maxdepth 1 -type f`; do \
+ install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
+ done; \
+ done
+ for dir in `find templates -follow -type d ! -regex '.*\.svn.*'`; do \
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
for file in `find $$dir -follow -maxdepth 1 -type f`; do \
install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \