aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2006-12-29 04:38:40 +0000
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2006-12-29 04:38:40 +0000
commit912521ef0711204965aa2319d41c7741bd3f4f4c (patch)
treeb0a3d21ddfc0b7ca4a8deaa26135d7c3309d3471 /Makefile.PL
parentd05d052bff599327cf43b6f00e337197f1d2ab18 (diff)
downloadikiwiki-912521ef0711204965aa2319d41c7741bd3f4f4c.tar
ikiwiki-912521ef0711204965aa2319d41c7741bd3f4f4c.tar.gz
* Initial work on internationalization of the program code. po/ikiwiki.pot
is available for translation. * Export gettext() from IkiWiki module.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index a6292a422..e0eaf4e32 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -32,10 +32,12 @@ extra_build:
./mdwn2man ikiwiki 1 doc/usage.mdwn > ikiwiki.man
./mdwn2man ikiwiki-mass-rebuild 8 doc/ikiwiki-mass-rebuild.mdwn > ikiwiki-mass-rebuild.man
./pm_filter $(PREFIX) $(VER) $(PROBABLE_INST_LIB) < ikiwiki.in > ikiwiki.out
-
+ $(MAKE) -C po
+
extra_clean:
rm -rf html doc/.ikiwiki
rm -f ikiwiki.man ikiwiki-mass-rebuild.man ikiwiki.out
+ $(MAKE) -C po clean
extra_install:
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/templates
@@ -58,6 +60,8 @@ extra_install:
install -d $(DESTDIR)$(PREFIX)/bin
install ikiwiki.out $(DESTDIR)$(PREFIX)/bin/ikiwiki
+
+ $(MAKE) -C po install
}
}