aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2007-04-10 00:26:15 +0000
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2007-04-10 00:26:15 +0000
commit88ffeae6eee4214cd96167b0f2ea646437a2bf23 (patch)
tree9f32e947992ca649e52fe3fd90ee9dbefe4d3761 /Makefile.PL
parent9c5be60e84abd5d645d0f4eb2f85eb7d3ec9419e (diff)
downloadikiwiki-88ffeae6eee4214cd96167b0f2ea646437a2bf23.tar
ikiwiki-88ffeae6eee4214cd96167b0f2ea646437a2bf23.tar.gz
* Add support for PROFILE=1 to the Makefile, this turns on profiling of the
wiki build using Devel::Profiler (Dprof can't handle ikiwiki).
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 3c47e684e..5bd1d6493 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -23,12 +23,13 @@ PROBABLE_INST_LIB=$(shell \\
fi \\
)
-tflag=$(shell if [ ! "$$NOTAINT" ]; then printf -- "-T"; fi)
+tflag=$(shell if [ "$$NOTAINT" != 0 ]; then printf -- "-T"; fi)
+extramodules=$(shell if [ "$$PROFILE" = 1 ]; then printf -- "-MDevel::Profiler"; fi)
extra_build:
./pm_filter $(PREFIX) $(VER) $(PROBABLE_INST_LIB) < ikiwiki.in > ikiwiki.out
chmod +x ikiwiki.out
- LANG=C perl -I. $(tflag) ikiwiki.out doc html --templatedir=templates \
+ LANG=C perl -I. $(extramodules) $(tflag) ikiwiki.out doc html --templatedir=templates \
--underlaydir=basewiki \
--wikiname="ikiwiki" --verbose \
--exclude=/discussion --no-discussion --userdir=users \
@@ -37,10 +38,11 @@ extra_build:
./mdwn2man ikiwiki 1 doc/usage.mdwn > ikiwiki.man
./mdwn2man ikiwiki-mass-rebuild 8 doc/ikiwiki-mass-rebuild.mdwn > ikiwiki-mass-rebuild.man
$(MAKE) -C po
+ if [ "$$PROFILE" = 1 ]; then dprofpp; fi
extra_clean:
rm -rf html doc/.ikiwiki
- rm -f ikiwiki.man ikiwiki-mass-rebuild.man ikiwiki.out
+ rm -f ikiwiki.man ikiwiki-mass-rebuild.man ikiwiki.out tmon.out
$(MAKE) -C po clean
extra_install: