aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-08-27 15:25:26 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-08-27 15:25:26 -0400
commit8709ec24825f29359c8f77d363c4126bf9c0742b (patch)
tree0f529e48cc0392fb52fcd40487e4548e7b22113f /Makefile.PL
parentf078eb5975b847fc8c0a770b47ed13e4bfb1fcd7 (diff)
downloadikiwiki-8709ec24825f29359c8f77d363c4126bf9c0742b.tar
ikiwiki-8709ec24825f29359c8f77d363c4126bf9c0742b.tar.gz
avoid installing .pyc files
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 1fc0bf371..979483c5a 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -72,7 +72,7 @@ extra_install:
for file in `find plugins -maxdepth 1 -type f ! -wholename plugins/.\* ! -name \*demo\* -name \*.py`; do \
install -m 644 $$file $(DESTDIR)$(PREFIX)/lib/ikiwiki/plugins; \
done
- for file in `find plugins -maxdepth 1 -type f ! -wholename plugins/.\* ! -name \*demo\* ! -name \*.py`; do \
+ for file in `find plugins -maxdepth 1 -type f ! -wholename plugins/.\* ! -name \*demo\* ! -name \*.py ! -name \*.pyc`; do \
install -m 755 $$file $(DESTDIR)$(PREFIX)/lib/ikiwiki/plugins; \
done