aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-01-12 19:04:24 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-01-12 19:04:24 -0500
commit6d785d6401799bf929316cb070471601798de4c0 (patch)
tree9cddd8e1b4a0fb5a7fb48cefb9048b3e4160d0fc /Makefile.PL
parent5b1f7f293dc5fed596f4745398b9c774b725a73b (diff)
downloadikiwiki-6d785d6401799bf929316cb070471601798de4c0.tar
ikiwiki-6d785d6401799bf929316cb070471601798de4c0.tar.gz
Add auto-blog.setup
It will set up an ikiwiki instance tuned for use in blogging. As part of this change, move the example sites into /usr/share/ikiwiki so they are available even if docs are not installed.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index d92d54d1e..d29804cca 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -69,6 +69,15 @@ extra_install:
install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/directives/ikiwiki/directive; \
fi \
done
+
+ # Install example sites.
+ for dir in `cd doc/examples; find -type d ! -regex '.*\.svn.*'`; do \
+ install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/examples/$$dir; \
+ done
+ for file in `cd doc/examples; find -type f ! -regex '.*\.svn.*'`; do \
+ cp -aL doc/examples/$$file $(DESTDIR)$(PREFIX)/share/ikiwiki/examples/$$file || \
+ install -m 644 doc/examples/$$file $(DESTDIR)$(PREFIX)/share/ikiwiki/examples/$$file; \
+ done
for dir in `find templates -follow -type d ! -regex '.*\.svn.*'`; do \
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
@@ -111,6 +120,7 @@ extra_install:
-install -d $(DESTDIR)/etc/ikiwiki
-install -m 0644 wikilist $(DESTDIR)/etc/ikiwiki
-install -m 0644 auto.setup $(DESTDIR)/etc/ikiwiki
+ -install -m 0644 auto-blog.setup $(DESTDIR)/etc/ikiwiki
}
}