aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2007-08-13 03:07:31 +0000
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2007-08-13 03:07:31 +0000
commit506bcbac0420a46997ad531961d543e62c011513 (patch)
tree8eaa71367c58158924077e61a3f6b2d1383cbb96 /Makefile.PL
parentb2101850e2098684a864e6143725247606da96bb (diff)
downloadikiwiki-506bcbac0420a46997ad531961d543e62c011513.tar
ikiwiki-506bcbac0420a46997ad531961d543e62c011513.tar.gz
* Fix --libdir to work at the command line.
* Plugins can now be written as standalone external programs, which can be written in any language that can do XML::RPC.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 985c944ad..0e306ac08 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -55,6 +55,11 @@ extra_install:
install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
done; \
done
+
+ install -d $(DESTDIR)$(PREFIX)/lib/ikiwiki/plugins
+ for file in `find plugins -maxdepth 1 -type f`; do \
+ install -m 755 $$file $(DESTDIR)$(PREFIX)/lib/ikiwiki/plugins; \
+ done; \
install -d $(DESTDIR)$(PREFIX)/share/man/man1
install -m 644 ikiwiki.man $(DESTDIR)$(PREFIX)/share/man/man1/ikiwiki.1