aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2006-08-13 02:03:43 +0000
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2006-08-13 02:03:43 +0000
commit4b36dee35a55b08d6d6f3bb3840220a4956f2540 (patch)
tree4202c4fa32c2ec537e065072e45b4bb9344b1147 /Makefile.PL
parent85ecbc6c4ea3af0b39034d985d4ca4adb243d94f (diff)
downloadikiwiki-4b36dee35a55b08d6d6f3bb3840220a4956f2540.tar
ikiwiki-4b36dee35a55b08d6d6f3bb3840220a4956f2540.tar.gz
* The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
* Add --version. * Man page format fixups. * Add a %pagecase which maps lower-case page names to the actual case used in the filename. Use this in bestlinks calculation instead of forcing the link to lowercase. * Also use %pagecase in various other places that want to check if a page with a given name exists. * This means that links to pages with mixed case names will now work, even if the link is in some other case mixture, and mixed case pages should be fully supported throughout ikiwiki. * Recommend rebuilding wikis on upgrade to this version.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 7b61acc61..1f46e9c95 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -11,6 +11,11 @@ clean:: extra_clean
install:: extra_install
pure_install:: extra_install
+VER=$(shell perl -e '$$_=<>;print m/\((.*?)\)/'<debian/changelog)
+
+ikiwiki: ikiwiki.pl
+ perl -pe '$$_="" if /use lib/; $$_="our \$$version=\"$(VER)\";\n" if /VERSION_AUTOREPLACE/' ikiwiki.pl > ikiwiki
+
extra_build:
./ikiwiki.pl doc html --templatedir=templates --underlaydir=basewiki \
--wikiname="ikiwiki" --verbose --no-rcs \
@@ -50,5 +55,6 @@ extra_install:
WriteMakefile(
'NAME' => 'IkiWiki',
'PM_FILTER' => 'grep -v "removed by Makefile"',
- 'EXE_FILES' => ['ikiwiki.pl'],
+ 'EXE_FILES' => ['ikiwiki'],
+ 'clean' => {FILES => 'ikiwiki'},
);