aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-10-19 19:25:23 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-10-19 19:25:23 -0400
commit4413307afa839ac906b7b504b6b580c4c2a98310 (patch)
tree087da9cb805846970103e82c8e429a2f24b0ccb5 /Makefile.PL
parent2b569f99d9e7f1d4d30c7f3adde9729ff4d868cf (diff)
downloadikiwiki-4413307afa839ac906b7b504b6b580c4c2a98310.tar
ikiwiki-4413307afa839ac906b7b504b6b580c4c2a98310.tar.gz
preserve underlay file times
I'd like to preserve the mtime and ctime of files in the underlay if possible, to avoid ikiwiki thinking they've changed and refreshing them each time it's upgraded. But, fall back to the old install command for systems that lack cp -a.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 95e574c66..2137b9dde 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -54,6 +54,7 @@ extra_install:
for dir in `cd underlays && find . -follow -type d ! -regex '.*\.svn.*'`; do \
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
for file in `find underlays/$$dir -follow -maxdepth 1 -type f`; do \
+ cp -aL $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir || \
install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
done; \
done