aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-06-03 11:37:13 -0400
committerJoey Hess <joey@kitenet.net>2011-06-03 11:37:13 -0400
commit2eec7fdd4321945e3ea507bd03b459e44cf264b4 (patch)
tree7953762cb302705427fa47d79a934b11f9241e0e /Makefile.PL
parenta42bbcb875aeb1e6715842cdb926952e18a3e439 (diff)
downloadikiwiki-2eec7fdd4321945e3ea507bd03b459e44cf264b4.tar
ikiwiki-2eec7fdd4321945e3ea507bd03b459e44cf264b4.tar.gz
don't install discussion pages for example sites
also dropped old .svn excludes
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.PL b/Makefile.PL
index df677262b..c3df9759b 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -67,7 +67,7 @@ myclean: clean
underlay_install:
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki
- for dir in `cd underlays && $(FIND) . -follow -type d ! -regex '.*\.svn.*'`; do \
+ for dir in `cd underlays && $(FIND) . -follow -type d`; do \
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
for file in `$(FIND) underlays/$$dir -follow -maxdepth 1 -type f`; do \
cp -aL $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir 2>/dev/null || \
@@ -102,15 +102,15 @@ underlay_install:
extra_install: underlay_install
# Install example sites.
- for dir in `cd doc/examples; $(FIND) . -type d ! -regex '.*\.svn.*'`; do \
+ for dir in `cd doc/examples; $(FIND) . -type d ! -regex '.*discussion.*'`; do \
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/examples/$$dir; \
done
- for file in `cd doc/examples; $(FIND) . -type f ! -regex '.*\.svn.*'`; do \
+ for file in `cd doc/examples; $(FIND) . -type f ! -regex '.*discussion.*'`; do \
cp -aL doc/examples/$$file $(DESTDIR)$(PREFIX)/share/ikiwiki/examples/$$file 2>/dev/null || \
install -m 644 doc/examples/$$file $(DESTDIR)$(PREFIX)/share/ikiwiki/examples/$$file; \
done
- for dir in `$(FIND) templates -follow -type d ! -regex '.*\.svn.*'`; do \
+ for dir in `$(FIND) templates -follow -type d`; do \
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
for file in `$(FIND) $$dir -follow -maxdepth 1 -type f`; do \
install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \