aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-08-21 23:12:14 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-08-21 23:12:14 -0400
commit15ed67132ee70a3c9c98565dee464a8f968c765c (patch)
tree3fedbf8c2b0fb0019eb1d91f024d16e6d3d809f9 /Makefile.PL
parent00a427129048f62476ab0386d06e038d222ecd8b (diff)
downloadikiwiki-15ed67132ee70a3c9c98565dee464a8f968c765c.tar
ikiwiki-15ed67132ee70a3c9c98565dee464a8f968c765c.tar.gz
Revert "Add missing PREFIX to a few lines of the Makefile. (Thomas Keller)"
This reverts commit 65c12dffecc49df2d8135a32121b9cabe8288cae. Turns out we can't use PREFIX for files in /etc, because that would tend to put them in /usr/etc, which is bad..
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index b0d56ee82..fa0b8ba49 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -48,9 +48,9 @@ extra_clean:
$(MAKE) -C po clean
extra_install:
- install -d $(DESTDIR)$(PREFIX)/etc/ikiwiki
- install -m 0644 wikilist $(DESTDIR)$(PREFIX)/etc/ikiwiki
- install -m 0644 auto.setup $(DESTDIR)$(PREFIX)/etc/ikiwiki
+ install -d $(DESTDIR)/etc/ikiwiki
+ install -m 0644 wikilist $(DESTDIR)/etc/ikiwiki
+ install -m 0644 auto.setup $(DESTDIR)/etc/ikiwiki
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki
for dir in `cd underlays && find . -follow -type d ! -regex '.*\.svn.*'`; do \