aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorAmitai Schlair <schmonz-web-ikiwiki@schmonz.com>2012-02-03 11:50:45 -0500
committerJoey Hess <joey@kitenet.net>2012-02-21 13:32:07 -0400
commit0c2841349b083b5bf549c2d1f1b44514a79b5a38 (patch)
treeb1fad52b9fc306e667b5f5f81a56cbae55b6fcdb /Makefile.PL
parentee975178b8befa0bfdc866c54bc3bfb64f570be2 (diff)
downloadikiwiki-0c2841349b083b5bf549c2d1f1b44514a79b5a38.tar
ikiwiki-0c2841349b083b5bf549c2d1f1b44514a79b5a38.tar.gz
Avoid a GNUism in find(1).
(cherry picked from commit 9659272e25fac37f896991dab01a05b4f4c85ccb)
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 69ba5e5ef..ef29a950c 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -75,7 +75,7 @@ underlay_install:
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki
for dir in `cd underlays && $(FIND) . -follow -type d`; do \
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
- for file in `$(FIND) underlays/$$dir -follow -maxdepth 1 -type f -not -name \\*.full.js -not -name \\*.full.css`; do \
+ for file in `$(FIND) underlays/$$dir -follow -maxdepth 1 -type f ! -name \\*.full.js ! -name \\*.full.css`; do \
cp -pRL $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir 2>/dev/null || \
install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
done; \