aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/version-control.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 6bd37fee82..dfc455ad88 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -58,6 +58,7 @@
;;; Copyright © 2024 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2024 Javier Olaechea <pirata@gmail.com>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
+;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2515,6 +2516,27 @@ changeset itself; there won't be any extra commits. Either GnuPG or OpenSSL
can be used for signing.")
(license license:gpl2)))) ;per commitsigs.py
+(define-public heatwave
+ (package
+ (name "heatwave")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "heatwave" version))
+ (sha256
+ (base32 "1zzwmb9hvbyswzjgap02rrq8p44hb6xlzk1wd8w01mh2vva0xlx7"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-click
+ python-gitpython
+ python-monthdelta))
+ (home-page "https://github.com/james-stoup/heatwave")
+ (synopsis "Heat map visualization of a git repository")
+ (description
+ "This package provides a way of visualizing a heat map of a git repo.")
+ (license license:gpl3)))
+
(define-public neon
(package
(name "neon")