aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2024-02-19 10:53:48 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-03 23:33:38 +0000
commit12455b36346f7ff0acf0811d9bddb657aa721075 (patch)
treeb777cf9230f1f4ec9726bbb9bf2626823e9be438 /gnu/packages
parente8d9a163be8fd3ae50329c92b106d9fb2c4c8227 (diff)
downloadguix-12455b36346f7ff0acf0811d9bddb657aa721075.tar
guix-12455b36346f7ff0acf0811d9bddb657aa721075.tar.gz
gnu: Add heatwave.
* gnu/packages/version-control.scm (python-heatwave): New variable. Change-Id: I640aecb3a0d9c454333a3913c039c637d24d9f79 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/version-control.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 6bd37fee82..dfc455ad88 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -58,6 +58,7 @@
;;; Copyright © 2024 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2024 Javier Olaechea <pirata@gmail.com>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
+;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2515,6 +2516,27 @@ changeset itself; there won't be any extra commits. Either GnuPG or OpenSSL
can be used for signing.")
(license license:gpl2)))) ;per commitsigs.py
+(define-public heatwave
+ (package
+ (name "heatwave")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "heatwave" version))
+ (sha256
+ (base32 "1zzwmb9hvbyswzjgap02rrq8p44hb6xlzk1wd8w01mh2vva0xlx7"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-click
+ python-gitpython
+ python-monthdelta))
+ (home-page "https://github.com/james-stoup/heatwave")
+ (synopsis "Heat map visualization of a git repository")
+ (description
+ "This package provides a way of visualizing a heat map of a git repo.")
+ (license license:gpl3)))
+
(define-public neon
(package
(name "neon")