aboutsummaryrefslogtreecommitdiff
path: root/etc
diff options
context:
space:
mode:
Diffstat (limited to 'etc')
-rwxr-xr-xetc/committer.scm.in20
-rwxr-xr-xetc/git/post-merge3
-rwxr-xr-xetc/git/pre-push4
-rw-r--r--etc/guix-daemon.conf.in2
-rw-r--r--etc/guix-daemon.service.in3
-rwxr-xr-xetc/guix-install.sh35
-rw-r--r--etc/init.d/guix-daemon.in4
-rw-r--r--etc/news.scm262
-rw-r--r--etc/release-manifest.scm12
-rwxr-xr-xetc/teams.scm29
10 files changed, 348 insertions, 26 deletions
diff --git a/etc/committer.scm.in b/etc/committer.scm.in
index 0705b29fd9..c49935da60 100755
--- a/etc/committer.scm.in
+++ b/etc/committer.scm.in
@@ -3,7 +3,7 @@
!#
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2020, 2021, 2022, 2023 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -255,10 +255,18 @@ corresponding to the top-level definition containing the staged changes."
(define* (change-commit-message file-name old new #:optional (port (current-output-port)))
"Print ChangeLog commit message for changes between OLD and NEW."
(define (get-values expr field)
- (match ((xpath:sxpath `(// ,field quasiquote *)) expr)
+ (match ((xpath:node-or
+ (xpath:sxpath `(*any* *any* package ,field quasiquote *))
+ ;; For let binding
+ (xpath:sxpath `(*any* *any* (*any*) package ,field quasiquote *)))
+ (cons '*TOP* expr))
(()
;; New-style plain lists
- (match ((xpath:sxpath `(// ,field list *)) expr)
+ (match ((xpath:node-or
+ (xpath:sxpath `(*any* *any* package ,field list *))
+ ;; For let binding
+ (xpath:sxpath `(*any* *any* (*any*) package ,field list *)))
+ (cons '*TOP* expr))
((inner) inner)
(_ '())))
;; Old-style labelled inputs
@@ -275,7 +283,11 @@ corresponding to the top-level definition containing the staged changes."
(define variable-name
(second old))
(define version
- (and=> ((xpath:sxpath '(// version *any*)) new)
+ (and=> ((xpath:node-or
+ (xpath:sxpath '(*any* *any* package version *any*))
+ ;; For let binding
+ (xpath:sxpath '(*any* *any* (*any*) package version *any*)))
+ (cons '*TOP* new))
first))
(format port
"gnu: ~a: Update to ~a.~%~%* ~a (~a): Update to ~a.~%"
diff --git a/etc/git/post-merge b/etc/git/post-merge
new file mode 100755
index 0000000000..f2ad37d35c
--- /dev/null
+++ b/etc/git/post-merge
@@ -0,0 +1,3 @@
+#!/bin/sh
+# Authenticate the repo upon 'git pull' and similar.
+exec guix git authenticate
diff --git a/etc/git/pre-push b/etc/git/pre-push
index 59671b0d58..325b23854b 100755
--- a/etc/git/pre-push
+++ b/etc/git/pre-push
@@ -32,7 +32,9 @@ do
# Only use the hook when pushing to Savannah.
case "$2" in
*.gnu.org*)
- exec make authenticate check-channel-news
+ set -e
+ make check-channel-news
+ exec guix git authenticate
exit 127
;;
*)
diff --git a/etc/guix-daemon.conf.in b/etc/guix-daemon.conf.in
index fb681d1f80..aa368d6272 100644
--- a/etc/guix-daemon.conf.in
+++ b/etc/guix-daemon.conf.in
@@ -7,4 +7,4 @@ start on runlevel [2345]
stop on runlevel [016]
-exec @localstatedir@/guix/profiles/per-user/root/current-guix/bin/guix-daemon --build-users-group=guixbuild --discover=no
+exec @localstatedir@/guix/profiles/per-user/root/current-guix/bin/guix-daemon --build-users-group=guixbuild --discover=no --substitute-urls='@GUIX_SUBSTITUTE_URLS@'
diff --git a/etc/guix-daemon.service.in b/etc/guix-daemon.service.in
index 5e75379b5e..5c43d9b7f1 100644
--- a/etc/guix-daemon.service.in
+++ b/etc/guix-daemon.service.in
@@ -7,7 +7,8 @@ Description=Build daemon for GNU Guix
[Service]
ExecStart=@localstatedir@/guix/profiles/per-user/root/current-guix/bin/guix-daemon \
- --build-users-group=guixbuild --discover=no
+ --build-users-group=guixbuild --discover=no \
+ --substitute-urls='@GUIX_SUBSTITUTE_URLS@'
Environment='GUIX_LOCPATH=@localstatedir@/guix/profiles/per-user/root/guix-profile/lib/locale' LC_ALL=en_US.utf8
StandardOutput=journal
StandardError=journal
diff --git a/etc/guix-install.sh b/etc/guix-install.sh
index 82accfd5d5..9d9c294d75 100755
--- a/etc/guix-install.sh
+++ b/etc/guix-install.sh
@@ -15,6 +15,7 @@
# Copyright © 2020 David A. Redick <david.a.redick@gmail.com>
# Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
# Copyright © 2024 Tomas Volf <~@wolfsden.cz>
+# Copyright © 2024 Richard Sent <richard@freakingpenguin.com>
#
# This file is part of GNU Guix.
#
@@ -81,6 +82,12 @@ REQUIRE=(
"xz"
)
+# Add variables using form FOO_INIT_REQUIRE when init system FOO dependencies
+# should be checked.
+SYSV_INIT_REQUIRE=(
+ "daemonize"
+)
+
PAS=$'[ \033[32;1mPASS\033[0m ] '
ERR=$'[ \033[31;1mFAIL\033[0m ] '
WAR=$'[ \033[33;1mWARN\033[0m ] '
@@ -148,6 +155,18 @@ chk_require()
_msg "${PAS}verification of required commands completed"
}
+add_init_sys_require()
+{ # Add the elements of FOO_INIT_SYS to REQUIRE
+ local init_require="${INIT_SYS}_REQUIRE[@]"
+ if [[ ! -z "$init_require" ]]; then
+ # Have to add piecemeal because ${!foo[@]} performs direct array key
+ # expansion, not indirect plain array expansion.
+ for r in "${!init_require}"; do
+ REQUIRE+=("$r")
+ done
+ fi
+}
+
chk_gpg_keyring()
{ # Check whether the Guix release signing public key is present.
_debug "--- [ ${FUNCNAME[0]} ] ---"
@@ -217,7 +236,7 @@ chk_init_sys()
_msg "${INF}init system is: sysv-init"
INIT_SYS="sysv-init"
return 0
- elif [[ $(openrc --version 2>/dev/null) =~ \(OpenRC\) ]]; then
+ elif [[ $(openrc --version 2>/dev/null) =~ \(OpenRC ]]; then
_msg "${INF}init system is: OpenRC"
INIT_SYS="openrc"
return 0
@@ -626,11 +645,6 @@ export XDG_CACHE_HOME="${XDG_CACHE_HOME:-$HOME/.cache}"
# _GUIX_PROFILE: `guix pull` profile
_GUIX_PROFILE="$HOME/.config/guix/current"
export PATH="$_GUIX_PROFILE/bin${PATH:+:}$PATH"
-# Export INFOPATH so that the updated info pages can be found
-# and read by both /usr/bin/info and/or $GUIX_PROFILE/bin/info
-# When INFOPATH is unset, add a trailing colon so that Emacs
-# searches 'Info-default-directory-list'.
-export INFOPATH="$_GUIX_PROFILE/share/info:$INFOPATH"
# GUIX_PROFILE: User's default profile and home profile
GUIX_PROFILE="$HOME/.guix-profile"
@@ -638,6 +652,12 @@ GUIX_PROFILE="$HOME/.guix-profile"
[ -L "$GUIX_PROFILE" ] && \
GUIX_LOCPATH="$GUIX_PROFILE/lib/locale${GUIX_LOCPATH:+:}$GUIX_LOCPATH"
+# Export INFOPATH so that the updated info pages can be found
+# and read by both /usr/bin/info and/or $GUIX_PROFILE/bin/info
+# When INFOPATH is unset, add a trailing colon so that Emacs
+# searches 'Info-default-directory-list'.
+export INFOPATH="$_GUIX_PROFILE/share/info:$GUIX_PROFILE/share/info:$INFOPATH"
+
GUIX_PROFILE="$HOME/.guix-home/profile"
[ -f "$GUIX_PROFILE/etc/profile" ] && . "$GUIX_PROFILE/etc/profile"
[ -L "$GUIX_PROFILE" ] && \
@@ -793,9 +813,10 @@ main_install()
_msg "Starting installation ($(date))"
chk_term
+ chk_init_sys
+ add_init_sys_require
chk_require "${REQUIRE[@]}"
chk_gpg_keyring
- chk_init_sys
chk_sys_arch
chk_sys_nscd
diff --git a/etc/init.d/guix-daemon.in b/etc/init.d/guix-daemon.in
index b7d4bb72bb..913210a543 100644
--- a/etc/init.d/guix-daemon.in
+++ b/etc/init.d/guix-daemon.in
@@ -36,7 +36,9 @@ start)
-E LC_ALL=en_US.utf8 \
-p "/var/run/guix-daemon.pid" \
@localstatedir@/guix/profiles/per-user/root/current-guix/bin/guix-daemon \
- --build-users-group=guixbuild --discover=no
+ --build-users-group=guixbuild --discover=no \
+ --substitute-urls='@GUIX_SUBSTITUTE_URLS@'
+
fi
;;
stop)
diff --git a/etc/news.scm b/etc/news.scm
index a511b7ffbc..a90f92a9ff 100644
--- a/etc/news.scm
+++ b/etc/news.scm
@@ -1,7 +1,7 @@
;; GNU Guix news, for use by 'guix pull'.
;;
;; Copyright © 2019-2024 Ludovic Courtès <ludo@gnu.org>
-;; Copyright © 2019–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;; Copyright © 2019–2021, 2024 Tobias Geerinckx-Rice <me@tobias.gr>
;; Copyright © 2019, 2020 Miguel Ángel Arruga Vivas <rosen644835@gmail.com>
;; Copyright © 2019, 2020 Konrad Hinsen <konrad.hinsen@fastmail.net>
;; Copyright © 2019, 2020, 2021, 2023 Julien Lepiller <julien@lepiller.eu>
@@ -23,6 +23,8 @@
;; Copyright © 2024 Hilton Chain <hako@ultrarare.space>
;; Copyright © 2024 Liliana Marie Prikler <liliana.prikler@gmail.com>
;; Copyright © 2024 Vivien Kraus <vivien@planete-kraus.eu>
+;; Copyright © 2024 Guillaume Le Vaillant <glv@posteo.net>
+;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;
;; Copying and distribution of this file, with or without modification, are
;; permitted in any medium without royalty provided the copyright notice and
@@ -31,6 +33,264 @@
(channel-news
(version 0)
+ (entry (commit "2fae63df2138b74d30e120364f0f272871595862")
+ (title
+ (en "Core packages updated")
+ (de "Kernpakete aktualisiert")
+ (fr "Logiciels fondamentaux mis à jour"))
+ (body
+ (en "Core packages have been updated, in particular those that
+are used to build every other package in the distribution. Noteworthy
+upgrades include:
+
+@itemize
+@item @code{glibc} 2.39 (was 2.35);
+@item @code{gcc} 11.4.0 as the default compiler (was 11.3.0);
+@item @code{binutils} 2.41 (was 2.38);
+@item @code{make} 4.4.1 (was 4.3);
+@item TeX@tie{}Live 2024.2 (was 20230313; note that due to the new
+versioning scheme, @command{guix upgrade} will consider the new packages
+as ``older'' than the previous ones so you may need to use
+@command{guix install} to upgrade them).
+@end itemize
+
+Additional improvements were made to build systems and related packages and
+tools:
+
+@itemize
+@item
+the @code{glibc} package now includes the @code{C.UTF-8} locale,
+suitable for use when a UTF-8 locale is necessary regardless of
+any language or regional convention;
+@item
+origins that include patches are now repacked with zstd instead of xz,
+which uses less CPU power and memory, both when compressing and when
+decompressing;
+@item
+performance issues with the modular TeX@tie{}Live package set have
+been fixed.
+@end itemize
+
+If you encounter any problem, please check
+@url{https://issues.guix.gnu.org} for existing reports and resolutions;
+email @email{bug-guix@@gnu.org} to report new bugs.")
+ (de "Pakete, die den Kern der Distribution ausmachen, wurden
+aktualisiert, insbesondere solche Pakete, aus denen heraus alle anderen Pakete
+der Distribution erstellt werden. Zu den nennenswerten Neuerungen gehören:
+
+@itemize
+@item @code{glibc} 2.39 (war 2.35),
+@item @code{gcc} 11.4.0 ist der voreingestellte Compiler (war 11.3.0),
+@item @code{binutils} 2.41 (war 2.38),
+@item @code{make} 4.4.1 (war 4.3),
+@item TeX@tie{}Live 2024.2 (war 20230313; das bedeutet, dass wegen der neuen
+Versionsbezeichnungen @command{guix upgrade} die neuen Pakete für „älter“ als
+die vorherigen hält und eine Aktualisierung unter Umständen nur zulässt, indem
+Sie @command{guix install} benutzen).
+@end itemize
+
+Weitere Verbesserungen wurden an Erstellungssystemen und zugehörigen Paketen
+und Werkzeugen vorgenommen:
+
+@itemize
+@item
+Zu dem Paket @code{glibc} gehört jetzt die Locale für @code{C.UTF-8}, die
+geeignet ist, wenn eine UTF-8-Locale gebraucht wird, aber Sprache und regionale
+Konventionen unwichtig sind.
+@item
+Paketursprünge mit Patches werden jetzt in Archive mit zstd anstelle von xz
+neu gepackt, wodurch weniger Rechenzeit und Speicher beim Komprimieren und
+Dekomprimieren nötig sind.
+@item
+Performance-Probleme mit den modularen Paketsatz von TeX@tie{}Live wurden
+behoben.
+@end itemize
+
+Wenn Sie Probleme feststellen, schauen Sie bitte auf
+@url{https://issues.guix.gnu.org} nach bisherigen Fehlerberichten und Lösungen
+und schicken Sie eine E-Mail an @email{bug-guix@@gnu.org}, um neue Fehler zu
+melden.")
+ (fr "Les logiciels fondamentaux on été mis à jour, en particulier
+ceux qui servent à construire tous les autres logiciels de la distribution.
+Les mises à jour notables sont :
+
+@itemize
+@item @code{glibc} 2.39 (au lieu de 2.35) ;
+@item @code{gcc} 11.4.0 comme compilateur par défaut (au lieu de 11.3.0) ;
+@item @code{binutils} 2.41 (au lieu de 2.38) ;
+@item @code{make} 4.4.1 (au lieu de 4.3) ;
+@item TeX@tie{}Live 2024.2 (au lieu de 20230313 ; compte tenu du changement de
+numérotation des versions, @command{guix upgrade} va croire que les nouveaux
+paquets sont « plus vieux » que les précédents et il faudra donc utiliser
+@command{guix install} pour les mettre à jour).
+@end itemize
+
+Les systèmes de construction ainsi que les paquets et outils connexes ont été
+améliorés :
+
+@itemize
+@item
+le paquet @code{glibc} inclut dorénavant la locale @code{C.UTF-8} qui convient
+chaque fois qu'on a besoin d'une locale UTF-8 indépendemment d'un langage ou
+de conventions régionales ;
+@item
+les origines qui incluent des @i{patches} sont maintenant recompressées avec
+zstd au lieu de xz, ce qui demande moins de temps de calcul et de mémoire, à
+la fois en compression et en décompression ;
+@item
+des problèmes de performance avec les paquets TeX@tie{}Live modulaires ont été
+résolus.
+@end itemize
+
+En cas de difficultés, merci de jeter un œil à
+@url{https://issues.guix.gnu.org} pour voir la liste des problèmes qui ont été
+remontés et les éventuelles solutions ; envoyer un courrier à
+@email{bug-guix@@gnu.org} pour faire remonter de nouveaux bogues.")))
+
+ (entry (commit "fc35b9fa6d6ed3583d4f3fc9214f657022d49678")
+ (title
+ (en "Linux-libre 6.9 removed due to end of upstream support")
+ (de "Linux-libre 6.9 wurde entfernt"))
+ (body
+ (en "The linux-libre 6.9 kernel series has reached the end of
+ its life, and is no longer supported upstream. For this
+ reason, it has been removed from GNU Guix.")
+ (de "Die @code{linux-libre} 6.9-Versionsreihe hat ihr
+Supportende erreicht und wird nicht mehr unterstützt („end of life“). Daher ist die
+Versionsreihe aus GNU Guix entfernt worden.")))
+
+ (entry (commit "4e58dfee6c7456d1e662f66041b8a157efe8710a")
+ (title
+ (en "More capable @code{privileged-programs} replace @code{setuid-programs}")
+ (de "Befähigtere @code{privileged-programs} ersetzen @code{setuid-programs}")
+ (nl "Capabelere @code{privileged-programs} vervangen @code{setuid-programs}"))
+ (body
+ (en "Where the kernel supports it, Guix System can now assign
+POSIX@tie{}@dfn{capabilities} to trusted executables. Capabilities offer a
+more granular alternative to the traditional setuid and setgid permissions,
+which remain available.
+
+To reflect this, @code{(gnu system setuid)} has been renamed to @code{(gnu
+system privilege)}. @code{privileged-programs} replaces @code{setuid-programs}
+as @code{operating-system} field and defaults to
+@code{%default-privileged-programs}. The executables themselves have moved from
+@file{/run/setuid-programs} to @file{/run/privileged/bin}.")
+ (de "Wo der Kernel dies unterstützt, kann Guix System nun
+POSIX-@dfn{Capabilities} an die Anwendungen vergeben, denen besonders vertraut
+wird. Capabilities bieten eine feinmaschigere Alternative zu den klassischen
+setuid- und setgid-Berechtigungen, die auch verfügbar bleiben.
+
+Um dies deutlich zu machen, heißt @code{(gnu system setuid)} nun @code{(gnu
+system privilege)}. Das Feld @code{privileged-programs} ersetzt
+@code{setuid-programs} in jedem @code{operating-system}-Objekt und sein
+Vorgabewert ist @code{%default-privileged-programs}. Die ausführbaren Dateien
+wurden von @file{/run/setuid-programs} nach @file{/run/privileged/bin}
+verschoben.")
+ (nl "Waar de kernel dit toelaat kan Guix System nu
+POSIX@tie{}@dfn{capabilities} toewijzen aan vertrouwde uitvoerbare bestanden.
+``Capabilities'' zijn een fijnmaziger alternatief voor de klassieke setuid- en
+setgid-rechten, die ook beschikbaar blijven.
+
+Om dit duidelijk te maken heet @code{(gnu system setuid)} nu @code{(gnu system
+privilege)}. @code{privileged-programs} vervangt @code{setuid-programs} als
+veld in het @code{operating-system} en heeft @code{%default-privileged-programs}
+als standaardwaarde. De uitvoerbare bestanden verhuizen van
+@file{/run/setuid-programs} naar @file{/run/privileged/bin}.")))
+ (entry (commit "26638b8e8129aa755586d017677b4cf076bafda6")
+ (title
+ (en "The containerd service is separated from @code{docker-service-type}")
+ (ru "Сервис containerd отделен от @code{docker-service-type}")
+ (de "containerd-Dienst wurde vom @code{docker-service-type} getrennt"))
+ (body
+ (en "containerd service has been decoupled from the
+@code{docker-service-type}. Moving forward, users are required to specify
+containerd settings manually for their configurations. The
+@code{containerd-service-type} service need to be added to a system
+configuration, otherwise a message about not any service provides
+@code{containerd} will be displayed during @code{guix system reconfigure}.
+
+Run @command{info \"(guix) Miscellaneous Services\"} for more info.")
+ (ru "Сервис containerd был отделен от @code{docker-service-type}.
+Впредь пользователям потребуется указывать параметры containerd вручную для
+своих конфигураций. Сервис @code{containerd-service-type} должен быть
+добавлен в конфигурацию системы, в противном случае будет отображено сообщение
+о том, что ни один сервис не предоставляет поддержку для @code{containerd} во
+время выполнения команды @code{guix system reconfigure}.
+
+Смотрите @command{info \"(guix.ru) Разнообразные службы\"} для получения более
+детальных сведений.")
+ (de "Es gibt einen eigenen containerd-Dienst losgelöst von
+@code{docker-service-type}. In Zukunft müssen Nutzer dort manuelle
+Einstellungen für containerd vornehmen. Der Dienst
+@code{containerd-service-type} muss zur Systemkonfiguration hinzugefügt
+werden, sonst wird durch @code{guix system reconfigure} eine Meldung
+gezeigt, dass kein Dienst @code{containerd} zur Verfügung stellt.
+
+Siehe @command{info \"(guix.de) Verschiedene Dienste\"} für genauere
+Informationen.")))
+
+ (entry (commit "ee7e5e00bf2b9257e67d785b37efddb008c5da37")
+ (title
+ (en "Plasma updated to version 6.1.2")
+ (de "Plasma auf Version 6.1.2 aktualisiert")
+ (fr "Plasma passe à la version 6.1.2")
+ (zh "Plasma 更新到 6.1.2 版本"))
+ (body
+ (en "Plasma updated to 6.1.2, KDE Frameworks updated to 6.3.0, and
+other KDE package updates.
+
+With Plasma updates, SDDM has QT6 enabled by default. If you want to still use a
+Qt5 theme, you need to set the field @code{sddm} in @code{sddm-configuration} to
+@code{sddm-qt5}.")
+ (de "Plasma wurde auf 6.1.2 aktualisiert, KDE Frameworks wurde
+auf 6.3.0 aktualisiert und andere KDE-Pakete wurden aktualisiert.
+
+Mit der Aktualisierung von Plasma ist in SDDM die Version qt6
+vorgegeben. Wenn Sie ein Qt5-Thema benutzen möchten, müssen Sie
+in der @code{sddm-configuration} das Feld @code{sddm} auf
+@code{sddm-qt5} setzen.")
+ (fr "Plasma passe à la version 6.1.2, KDE Frameworks à la 6.3.0, et
+ d’autres logiciels KDE sont mis à jour.
+
+ Avec ces mises à jour de Plasma, sddm utilise Qt 6 par défaut. Pour
+ utiliser un thème Qt 5, il faut mettre le champ @code{sddm} de
+ @code{sddm-configuration} à @code{sddm-qt5}.")
+ (zh "Plasma 更新到 6.1.2, KDE Frameworks 更新到 6.3.0, 及其他 KDE 软件包更新。
+
+随着 Plasma 更新, SDDM 默认启用 Qt6, 如果您还想使用 Qt5 主题, 需要将 @code{sddm-configuration} 中的
+@code{sddm} 字段设置为 @code{sddm-qt5}.")))
+
+ (entry (commit "a46908620fac09bd8ccd0f587a27e86035d3b1d7")
+ (title
+ (en "@code{stumpwm:lib} removed")
+ (de "@code{stumpwm:lib} wurde entfernt")
+ (fr "@code{stumpwm:lib} supprimé"))
+ (body
+ (en "The @code{lib} output of the @code{stumpwm} package has been
+removed. If you have some personal package definitions depending on
+@code{stumpwm:lib}, they should be updated to depend on @code{stumpwm}
+instead.")
+ (de "Die Ausgabe @code{lib} des Pakets @code{stumpwm} gibt es nicht
+mehr. Wenn Sie eigene Paketdefinitionen haben, die von @code{stumpwm:lib}
+abhängen, müssen sie angepasst werden, um stattdessen von @code{stumpwm}
+abzuhängen.")
+ (fr "La sortie @code{lib} du paquet @code{stumpwm} a été supprimée.
+Si vous avez des définitions de paquets personnels dépendantes de
+@code{stumpwm:lib}, elle doivent être modifiées pour dépendre de
+@code{stumpwm} à la place.")))
+
+ (entry (commit "6fad0fd1c32db2cb25447b694f08d5c7836536ad")
+ (title
+ (en "Linux-libre 6.8 removed due to end of upstream support")
+ (de "Linux-libre 6.8 wurde entfernt"))
+ (body
+ (en "The linux-libre 6.8 kernel series has reached the end of
+ its life, and is no longer supported upstream. For this
+ reason, it has been removed from GNU Guix.")
+ (de "Die @code{linux-libre} 6.8-Versionsreihe hat ihr
+Supportende erreicht und wird nicht mehr unterstützt („end of life“). Daher ist die
+Versionsreihe aus GNU Guix entfernt worden.")))
+
(entry (commit "8d1d98a3aa3448b9d983e4bd64243a938b96e8ab")
(title
(en "@command{guix git authenticate} usage simplified")
diff --git a/etc/release-manifest.scm b/etc/release-manifest.scm
index 773910ac80..b003f216ff 100644
--- a/etc/release-manifest.scm
+++ b/etc/release-manifest.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2020-2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2020-2022, 2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
;;;
@@ -145,6 +145,16 @@ TARGET."
"x86_64-linux-gnu"
"i686-linux-gnu"
+ ;; Ignore obsolete systems, as in (gnu ci).
+ "mips64el-linux-gnu"
+ "powerpc-linux-gnu"
+ "powerpc64-linux-gnu"
+
+ ;; Ignore bare-metal targets.
+ "avr"
+ "or1k-elf"
+ "xtensa-ath9k-elf"
+
;; XXX: Important bits like libsigsegv and libffi don't
;; support RISCV at the moment, so don't require RISCV
;; support.
diff --git a/etc/teams.scm b/etc/teams.scm
index 8dfd1b20a7..9239021b39 100755
--- a/etc/teams.scm
+++ b/etc/teams.scm
@@ -454,7 +454,9 @@ asdf-build-system."
"gnu/packages/cross-base.scm"
"gnu/packages/gcc.scm"
"gnu/packages/guile.scm"
+ "gnu/packages/ld-wrapper.in"
"gnu/packages/make-bootstrap.scm"
+ "gnu/packages/multiprecision.scm"
"guix/build/gnu-build-system.scm"
"guix/build/utils.scm"
"guix/build-system/gnu.scm")))
@@ -510,11 +512,12 @@ asdf-build-system."
(team 'mozilla
#:name "Mozilla"
#:description
- "Taking care about Icecat and Icedove, built from Mozilla Firefox
-and Thunderbird."
+ "Taking care of Icedove and Web Browsers based on Mozilla Thunderbird
+and Firefox."
#:scope (list "gnu/build/icecat-extension.scm"
"gnu/packages/browser-extensions.scm"
"gnu/packages/gnuzilla.scm"
+ "gnu/packages/librewolf.scm"
"gnu/packages/tor-browsers.scm")))
(define-team racket
@@ -596,7 +599,7 @@ GLib/GIO, GTK, GStreamer and Webkit."
(define-member (person "Andreas Enge"
"andreas@enge.fr")
- lxqt science tex)
+ bootstrap core-packages lxqt science tex)
(define-member (person "Tanguy Le Carrour"
"tanguy@bioneland.org")
@@ -604,7 +607,7 @@ GLib/GIO, GTK, GStreamer and Webkit."
(define-member (person "Tobias Geerinckx-Rice"
"me@tobias.gr")
- core kernel mentors)
+ core mentors)
(define-member (person "Leo Famulari"
"leo@famulari.name")
@@ -644,7 +647,7 @@ GLib/GIO, GTK, GStreamer and Webkit."
(define-member (person "Ricardo Wurmus"
"rekado@elephly.net")
- core mentors r sugar tex)
+ r sugar)
(define-member (person "Christopher Baines"
"guix@cbaines.net")
@@ -668,7 +671,7 @@ GLib/GIO, GTK, GStreamer and Webkit."
(define-member (person "Simon Tournier"
"zimon.toutoune@gmail.com")
- julia core mentors)
+ julia core mentors r)
(define-member (person "宋文武"
"iyzsong@envs.net")
@@ -734,9 +737,17 @@ GLib/GIO, GTK, GStreamer and Webkit."
"adam.faiz@disroot.org")
games)
-(define-member (person "Matthew Trzcinski"
- "matt@excalamus.com")
- documentation)
+(define-member (person "Laurent Gatto"
+ "laurent.gatto@gmail.com")
+ r)
+
+(define-member (person "Nicolas Goaziou"
+ "guix@nicolasgoaziou.fr")
+ tex)
+
+(define-member (person "André Batista"
+ "nandre@riseup.net")
+ mozilla)
(define (find-team name)