aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-06-08 10:27:07 +0100
committerChristopher Baines <mail@cbaines.net>2019-06-08 10:27:07 +0100
commit88922d9f11554288956ad002c04094022a7db84d (patch)
treee16cb65e2782fd54df19be470d062fd4be4a20cb /Makefile.am
parent42c608e00417a3f57f9c410daca1f84b3f9550bc (diff)
downloaddata-service-88922d9f11554288956ad002c04094022a7db84d.tar
data-service-88922d9f11554288956ad002c04094022a7db84d.tar.gz
Tweak the Makefile.am to install the right things
Install the assets and sqitch files, as they are needed. Remove the test related sources.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1bb1b58..758f5e8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,6 +30,16 @@ moddir = $(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
godir = $(moddir)
assetsdir = $(datadir)/@PACKAGE@
+install-data-local:
+ mkdir -p "$(DESTDIR)$(pkgdatadir)" || exit 1;
+ cp -r assets "$(DESTDIR)$(pkgdatadir)/" || exit 1;
+ cp -r sqitch "$(DESTDIR)$(pkgdatadir)/" || exit 1;
+
+install-data-hook:
+# These files shouldn't be installed, but I have no idea how to specify that
+# :(
+ rm -r "$(DESTDIR)$(moddir)/tests"
+
SOURCES = \
guix-data-service/branch-updated-emails.scm \
guix-data-service/builds.scm \