aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1bb1b58..758f5e8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,6 +30,16 @@ moddir = $(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
godir = $(moddir)
assetsdir = $(datadir)/@PACKAGE@
+install-data-local:
+ mkdir -p "$(DESTDIR)$(pkgdatadir)" || exit 1;
+ cp -r assets "$(DESTDIR)$(pkgdatadir)/" || exit 1;
+ cp -r sqitch "$(DESTDIR)$(pkgdatadir)/" || exit 1;
+
+install-data-hook:
+# These files shouldn't be installed, but I have no idea how to specify that
+# :(
+ rm -r "$(DESTDIR)$(moddir)/tests"
+
SOURCES = \
guix-data-service/branch-updated-emails.scm \
guix-data-service/builds.scm \