aboutsummaryrefslogtreecommitdiff
path: root/guix/platforms
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2023-11-28 12:34:46 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-12-11 11:53:54 +0200
commitbe5ec2ebb4bde4b4f702a30f08849dff05cceccd (patch)
tree1e4f3078f49528e5fb8e93e5c0f126e77490febd /guix/platforms
parentb40a44430f94a9381eb9c8170985bc44e73252f3 (diff)
downloadguix-be5ec2ebb4bde4b4f702a30f08849dff05cceccd.tar
guix-be5ec2ebb4bde4b4f702a30f08849dff05cceccd.tar.gz
guix: Add avr platform.
* Makefile.am (MODULES): Add avr platform module. * doc/guix.texi: Add documentation for avr platform. * guix/platforms/avr.scm (avr): New variable. Change-Id: I0f425eac61a71390b618e093f5a034ad4205a6f4 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'guix/platforms')
-rw-r--r--guix/platforms/avr.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/guix/platforms/avr.scm b/guix/platforms/avr.scm
new file mode 100644
index 0000000000..ba178db6ea
--- /dev/null
+++ b/guix/platforms/avr.scm
@@ -0,0 +1,28 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix platforms avr)
+ #:use-module (guix platform)
+ #:use-module (guix records)
+ #:export (avr))
+
+(define avr
+ (platform
+ (target "avr")
+ (system #f)
+ (glibc-dynamic-linker #f)))