aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2023-11-28 12:34:46 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-12-11 11:53:54 +0200
commitbe5ec2ebb4bde4b4f702a30f08849dff05cceccd (patch)
tree1e4f3078f49528e5fb8e93e5c0f126e77490febd
parentb40a44430f94a9381eb9c8170985bc44e73252f3 (diff)
downloadguix-be5ec2ebb4bde4b4f702a30f08849dff05cceccd.tar
guix-be5ec2ebb4bde4b4f702a30f08849dff05cceccd.tar.gz
guix: Add avr platform.
* Makefile.am (MODULES): Add avr platform module. * doc/guix.texi: Add documentation for avr platform. * guix/platforms/avr.scm (avr): New variable. Change-Id: I0f425eac61a71390b618e093f5a034ad4205a6f4 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--Makefile.am1
-rw-r--r--doc/guix.texi7
-rw-r--r--guix/platforms/avr.scm28
3 files changed, 36 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cbc3191dfc..9784b19054 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -138,6 +138,7 @@ MODULES = \
guix/ipfs.scm \
guix/platform.scm \
guix/platforms/arm.scm \
+ guix/platforms/avr.scm \
guix/platforms/mips.scm \
guix/platforms/powerpc.scm \
guix/platforms/riscv.scm \
diff --git a/doc/guix.texi b/doc/guix.texi
index 7dde9b727b..3ad8508a32 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -119,6 +119,7 @@ Copyright @copyright{} 2023 Tanguy Le Carrour@*
Copyright @copyright{} 2023 Zheng Junjie@*
Copyright @copyright{} 2023 Brian Cully@*
Copyright @copyright{} 2023 Felix Lechner@*
+Copyright @copyright{} 2023 Foundation Devices, Inc.@*
Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.3 or
@@ -16760,6 +16761,7 @@ The available targets are:
- aarch64-linux-gnu
- arm-linux-gnueabihf
+ - avr
- i586-pc-gnu
- i686-linux-gnu
- i686-w64-mingw32
@@ -45850,6 +45852,11 @@ Platform targeting x86 CPU running GNU/Hurd (also referred to as
``GNU'').
@end defvar
+@defvar avr
+Platform targeting AVR CPUs without an operating system, with run-time support
+from AVR Libc.
+@end defvar
+
@node System Images
@chapter Creating System Images
diff --git a/guix/platforms/avr.scm b/guix/platforms/avr.scm
new file mode 100644
index 0000000000..ba178db6ea
--- /dev/null
+++ b/guix/platforms/avr.scm
@@ -0,0 +1,28 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix platforms avr)
+ #:use-module (guix platform)
+ #:use-module (guix records)
+ #:export (avr))
+
+(define avr
+ (platform
+ (target "avr")
+ (system #f)
+ (glibc-dynamic-linker #f)))