aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:56:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:11 +0200
commitf2b8f7f7e1da06f8a1b58bf763d4b6c23abf1f40 (patch)
tree14aa2a3e7c349948a04f6b28819ea80a2fafb46d /gnu
parentce5395416c59b5be99df936eb37b08240246cbe8 (diff)
downloadguix-f2b8f7f7e1da06f8a1b58bf763d4b6c23abf1f40.tar
guix-f2b8f7f7e1da06f8a1b58bf763d4b6c23abf1f40.tar.gz
gnu: Add texlive-tzplot.
* gnu/packages/tex.scm (texlive-tzplot): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cd302d60c1..31e510dc40 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5620,6 +5620,27 @@ open source emojis through LaTeX commands. This relies on images, so no fancy
Unicode font stuff is needed and it should work on every installation.")
(license (list license:lppl1.3+ license:cc-by4.0))))
+(define-public texlive-tzplot
+ (package
+ (name "texlive-tzplot")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tzplot/" "tex/latex/tzplot/")
+ (base32
+ "09k84vjvl3qkp8jffv3j5bksq3jaad2p71yj715z39qf36hwvm7s")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tzplot")
+ (synopsis "Plot graphs with TikZ abbreviations")
+ (description
+ "This is a LaTeX package that provides TikZ-based macros to make it easy
+to draw graphs. The macros provided in this package are just abbreviations
+for TikZ codes, which can be complicated; but using the package will hopefully
+make drawing easier, especially when drawing repeatedly. The macros were
+chosen and developed with an emphasis on drawing graphs in economics.")
+ (license license:lppl1.3c)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")