aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:56:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:11 +0200
commitce5395416c59b5be99df936eb37b08240246cbe8 (patch)
treee5be3b29bce05fec0a4cfca4c836e57873a1908f /gnu
parent8332766a60580a9b9cb4bc681f763751a482d0e7 (diff)
downloadguix-ce5395416c59b5be99df936eb37b08240246cbe8.tar
guix-ce5395416c59b5be99df936eb37b08240246cbe8.tar.gz
gnu: Add texlive-twemojis.
* gnu/packages/tex.scm (texlive-twemojis): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c92ab4eeb9..cd302d60c1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5599,6 +5599,27 @@ which produced lines at an arbitrary orientation. The present package
emulates the macro, using TikZ.")
(license license:public-domain)))
+(define-public texlive-twemojis
+ (package
+ (name "texlive-twemojis")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/twemojis/"
+ "source/latex/twemojis/"
+ "tex/latex/twemojis/")
+ (base32
+ "0wim1325dcx779305cany8rsifi67y8pbwifs4qbh090dzx5sy6r")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/twemojis")
+ (synopsis "Use Twitter's open source emojis through LaTeX commands")
+ (description
+ "This package provides a simple wrapper which allows to use Twitter's
+open source emojis through LaTeX commands. This relies on images, so no fancy
+Unicode font stuff is needed and it should work on every installation.")
+ (license (list license:lppl1.3+ license:cc-by4.0))))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")