aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-10-02 10:08:15 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-30 19:32:18 +0000
commitf021b7e7e3b695c2eee1981e452c99d7518d63bc (patch)
tree8060f44f3727ac59ee4821e54d85b5f598669dba /gnu
parent1b598839c753d0f930cdaffecb47a55c1f1c7731 (diff)
downloadguix-f021b7e7e3b695c2eee1981e452c99d7518d63bc.tar
guix-f021b7e7e3b695c2eee1981e452c99d7518d63bc.tar.gz
gnu: Add python-pysiril.
* gnu/packages/astronomy.scm (python-pysiril): New variable. Change-Id: Ia7ed4c4707464254a02c4db6eab4c857dbd959f0
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 06b27f190c..378272715d 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2081,6 +2081,30 @@ that path, and along the spectral axis, producing a position-velocity or
position-frequency slice.")
(license license:bsd-3)))
+(define-public python-pysiril
+ (package
+ (name "python-pysiril")
+ (version "0.0.17")
+ (source
+ (origin
+ (method git-fetch) ; not published on PyPI
+ (uri (git-reference
+ (url "https://gitlab.com/free-astro/pysiril")
+ (commit (string-append
+ "V" (string-replace-substring version "." "_")))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0w8zc6gm8a18l4rvjv22a0l6m2c45bzj1f2m6sbshaq9z30bm0vv"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ; no tests
+ (home-page "https://siril.org/tutorials/pysiril/")
+ (synopsis "Python interface to SiriL")
+ (description
+ "This package provides an extending scripting capabilities, present
+natively in Siril.")
+ (license license:gpl3)))
+
(define-public python-pyxsim
(package
(name "python-pyxsim")