aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-10-01 20:21:20 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-30 19:32:17 +0000
commit1b598839c753d0f930cdaffecb47a55c1f1c7731 (patch)
tree93aa700ecd22487dffd139eb37c2874eeda13bf2 /gnu
parent3f7ccf450d45874955538cebe9f42deca0ff3f90 (diff)
downloadguix-1b598839c753d0f930cdaffecb47a55c1f1c7731.tar
guix-1b598839c753d0f930cdaffecb47a55c1f1c7731.tar.gz
gnu: Add python-hsluv.
* gnu/packages/python-xyz.scm (python-hsluv): New variable. Change-Id: I97a5b09f66150f0d77f62caa7c8f8410807d5340
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b11a33fa52..f810463435 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11512,6 +11512,26 @@ The output of all running processes is collected by honcho and
displayed.")
(license license:expat)))
+(define-public python-hsluv
+ (package
+ (name "python-hsluv")
+ (version "5.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "hsluv" version))
+ (sha256
+ (base32 "0bmpd7qxcvin8szblilxmw50v7mygf6a6i180h82123s893gk092"))))
+ (build-system pyproject-build-system)
+ (home-page "https://www.hsluv.org")
+ (synopsis "Human-friendly HSL colour space implemented in Python")
+ (description
+ "Human-friendly @acronym{Hue Saturation Lightness,HSL}. HSLuv extends
+@url{http://en.wikipedia.org/wiki/CIELUV,CIELUV} with a new saturation
+component that allows you to span all the available chroma as a neat
+percentage.")
+ (license license:expat)))
+
(define-public python-pebble
(package
(name "python-pebble")