aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-12-26 21:44:25 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-12-28 22:14:16 -0500
commitd6ea9f8b38df7de1194d8106488a8c33cce64fd1 (patch)
tree61a856a1bade8830c5d8117c9b25f89e9abf8411 /gnu
parent783b85f6436fba3bc7155be33da8fdcf16c4877a (diff)
downloadguix-d6ea9f8b38df7de1194d8106488a8c33cce64fd1.tar
guix-d6ea9f8b38df7de1194d8106488a8c33cce64fd1.tar.gz
gnu: u-boot-am335x-boneblack: Revert to old name.
This reverts to the name this package had previous to commit c2c1dfdf5760873f1db86d14873f725a105f7feb ("gnu: bootloader: Add U-Boot packages for Raspberry Pi models."), which caused the package name to be derived from the board name. * gnu/packages/bootloaders.scm (u-boot-am335x-evm-boneblack): Remove the NAME-SUFFIX keyword argument. Specify the full name via the name field. * gnu/bootloader/u-boot.scm (u-boot-beaglebone-black-bootloader): Adjust to the renamed package. Reported-by: Vagrant Cascadian <vagrant@debian.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/bootloader/u-boot.scm2
-rw-r--r--gnu/packages/bootloaders.scm28
2 files changed, 18 insertions, 12 deletions
diff --git a/gnu/bootloader/u-boot.scm b/gnu/bootloader/u-boot.scm
index de3a43ed70..6cad33b741 100644
--- a/gnu/bootloader/u-boot.scm
+++ b/gnu/bootloader/u-boot.scm
@@ -144,7 +144,7 @@
(define u-boot-beaglebone-black-bootloader
(bootloader
(inherit u-boot-bootloader)
- (package u-boot-am335x-evm-boneblack)
+ (package u-boot-am335x-boneblack)
(disk-image-installer install-beaglebone-black-u-boot)))
(define u-boot-allwinner-bootloader
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 406f885253..e3a63882e9 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -963,17 +963,23 @@ appended to the package description."
(define-public u-boot-malta
(make-u-boot-package "malta" "mips64el-linux-gnuabi64"))
-(define-public u-boot-am335x-evm-boneblack
- (make-u-boot-package
- "am335x_evm" "arm-linux-gnueabihf"
- ;; Patch out other device trees to build an image small enough to fit
- ;; within typical partitioning schemes where the first partition begins at
- ;; sector 2048.
- #:configs '("CONFIG_OF_LIST=\"am335x-evm am335x-boneblack\"")
- #:name-suffix "-boneblack"
- #:append-description "This U-Boot is built for the BeagleBone Black, which
-was removed upstream, adjusted from the am335x_evm build with several device
-trees removed so that it fits within common partitioning schemes."))
+(define-public u-boot-am335x-boneblack
+ (let ((base (make-u-boot-package
+ "am335x_evm" "arm-linux-gnueabihf"
+ ;; Patch out other device trees to build an image small enough
+ ;; to fit within typical partitioning schemes where the first
+ ;; partition begins at sector 2048.
+ #:configs '("CONFIG_OF_LIST=\"am335x-evm am335x-boneblack\"")
+ #:append-description
+ "This U-Boot is built for the BeagleBone Black, which was
+removed upstream, adjusted from the am335x_evm build with several device trees
+removed so that it fits within common partitioning schemes.")))
+ (package
+ (inherit base)
+ ;; The name is not derived from the board name on purpose, as the config
+ ;; is modified per the comment above, parting from the default
+ ;; am335x_evm configuration.
+ (name "u-boot-am335x-boneblack"))))
(define-public u-boot-am335x-evm
(make-u-boot-package "am335x_evm" "arm-linux-gnueabihf"))