aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/bootloader/u-boot.scm2
-rw-r--r--gnu/packages/bootloaders.scm28
2 files changed, 18 insertions, 12 deletions
diff --git a/gnu/bootloader/u-boot.scm b/gnu/bootloader/u-boot.scm
index de3a43ed70..6cad33b741 100644
--- a/gnu/bootloader/u-boot.scm
+++ b/gnu/bootloader/u-boot.scm
@@ -144,7 +144,7 @@
(define u-boot-beaglebone-black-bootloader
(bootloader
(inherit u-boot-bootloader)
- (package u-boot-am335x-evm-boneblack)
+ (package u-boot-am335x-boneblack)
(disk-image-installer install-beaglebone-black-u-boot)))
(define u-boot-allwinner-bootloader
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 406f885253..e3a63882e9 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -963,17 +963,23 @@ appended to the package description."
(define-public u-boot-malta
(make-u-boot-package "malta" "mips64el-linux-gnuabi64"))
-(define-public u-boot-am335x-evm-boneblack
- (make-u-boot-package
- "am335x_evm" "arm-linux-gnueabihf"
- ;; Patch out other device trees to build an image small enough to fit
- ;; within typical partitioning schemes where the first partition begins at
- ;; sector 2048.
- #:configs '("CONFIG_OF_LIST=\"am335x-evm am335x-boneblack\"")
- #:name-suffix "-boneblack"
- #:append-description "This U-Boot is built for the BeagleBone Black, which
-was removed upstream, adjusted from the am335x_evm build with several device
-trees removed so that it fits within common partitioning schemes."))
+(define-public u-boot-am335x-boneblack
+ (let ((base (make-u-boot-package
+ "am335x_evm" "arm-linux-gnueabihf"
+ ;; Patch out other device trees to build an image small enough
+ ;; to fit within typical partitioning schemes where the first
+ ;; partition begins at sector 2048.
+ #:configs '("CONFIG_OF_LIST=\"am335x-evm am335x-boneblack\"")
+ #:append-description
+ "This U-Boot is built for the BeagleBone Black, which was
+removed upstream, adjusted from the am335x_evm build with several device trees
+removed so that it fits within common partitioning schemes.")))
+ (package
+ (inherit base)
+ ;; The name is not derived from the board name on purpose, as the config
+ ;; is modified per the comment above, parting from the default
+ ;; am335x_evm configuration.
+ (name "u-boot-am335x-boneblack"))))
(define-public u-boot-am335x-evm
(make-u-boot-package "am335x_evm" "arm-linux-gnueabihf"))