aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNiklas Eklund <niklas.eklund@posteo.net>2021-06-15 19:55:10 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-18 12:01:17 +0200
commitd4b86bac974fe133af629f5de25955339173f9ab (patch)
tree384eea58f374034b38f08b98e75220f8861de304 /gnu
parentd640ae44e8ad68060a35421b86bdc340472235a0 (diff)
downloadguix-d4b86bac974fe133af629f5de25955339173f9ab.tar
guix-d4b86bac974fe133af629f5de25955339173f9ab.tar.gz
gnu: Add emacs-flycheck-package.
* gnu/emacs-xyz.scm (emacs-flycheck-package): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8f23e1856f..ca87a2ed46 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -78,7 +78,7 @@
;;; Copyright © 2020 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2020, 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 Peng Mei Yu <i@pengmeiyu.com>
-;;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
+;;; Copyright © 2020, 2021 Niklas Eklund <niklas.eklund@posteo.net>
;;; Copyright © 2020 Marco Grassi <marco.au.grassi98@protonmail.com>
;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
@@ -5576,6 +5576,31 @@ errors.")
the current Cargo project.")
(license license:gpl3+)))
+(define-public emacs-flycheck-package
+ (package
+ (name "emacs-flycheck-package")
+ (version "0.14")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/purcell/flycheck-package")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00py39n1383761wq6wp194pvyk94ydqdbxj9kl64g9jnipkp7849"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-flycheck" ,emacs-flycheck)
+ ("emacs-package-lint" ,emacs-package-lint)))
+ (home-page "https://github.com/purcell/flycheck-package")
+ (synopsis "Flycheck checker for elisp package metadata")
+ (description
+ "This library provides a flycheck checker for the metadata in Emacs Lisp
+files which are intended to be packages.")
+ (license license:gpl3+)))
+
(define-public emacs-elisp-demos
(package
(name "emacs-elisp-demos")