aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-06-13 15:47:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-18 11:59:52 +0200
commitd640ae44e8ad68060a35421b86bdc340472235a0 (patch)
tree8e9a82abe29d99387883895a0670f48f410461fb /gnu
parent9f1d2085dfa96c37e0c1a2d6eb21793625603f71 (diff)
downloadguix-d640ae44e8ad68060a35421b86bdc340472235a0.tar
guix-d640ae44e8ad68060a35421b86bdc340472235a0.tar.gz
gnu: Add emacs-package-build.
* gnu/packages/emacs-xyz.scm (emacs-package-build): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index df04fb4412..8f23e1856f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -532,6 +532,26 @@ buffers, directory trees, or the web.")
@command{hg histedit} for editing the commit history.")
(license license:gpl3+))))
+(define-public emacs-package-build
+ (package
+ (name "emacs-package-build")
+ (version "2.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/melpa/package-build")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1412pjghyvzkdlsrrs0ql30vw591bhyk1wlbf49f15dzjbspx3w0"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/melpa/package-build")
+ (synopsis "Tools for assembling en Emacs package archive")
+ (description "This package provides tools for assembling an @acronym{ELPA,
+Emacs package archive}.")
+ (license license:gpl3+)))
+
(define-public emacs-paredit
(package
(name "emacs-paredit")