aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-24 23:28:51 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:01:02 +0100
commitb167bab9a1040fad0477c4bffc728e5b36837fd5 (patch)
tree61ee8b2bbbab2ec41056da96de26f271cbe87476 /gnu
parentda5d887f6fd9240f504f02bb42c10183b4d85ab2 (diff)
downloadguix-b167bab9a1040fad0477c4bffc728e5b36837fd5.tar
guix-b167bab9a1040fad0477c4bffc728e5b36837fd5.tar.gz
gnu: go-github-com-cespare-xxhash: Rename variable.
* gnu/packages/golang-crypto.scm (go-github-com-cespare-xxhash): Rename to go-github-com-cespare-xxhash-v2 to reflect go.mod import path. * gnu/packages/golang-xyz.scm (go-github-com-coocood-freecache) [propagated-inputs]: Remove go-github-com-cespare-xxhash, add go-github-com-cespare-xxhash-v2. * gnu/packages/networking.scm (nebula) [native-inputs]: Remove go-github-com-cespare-xxhash, add go-github-com-cespare-xxhash-v2. * gnu/packages/textutils.scm (csvdiff): Likewise. Change-Id: I4d26cea51178d25962933ff6f19f0afafef61d6d
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-crypto.scm6
-rw-r--r--gnu/packages/golang-xyz.scm2
-rw-r--r--gnu/packages/networking.scm2
-rw-r--r--gnu/packages/textutils.scm2
4 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index e89c486bcc..8783c19443 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -355,9 +355,9 @@ needing to use secp256k1 elliptic curve cryptography.")
the Ristretto prime-order group built from Edwards25519.")
(license license:expat)))
-(define-public go-github-com-cespare-xxhash
+(define-public go-github-com-cespare-xxhash-v2
(package
- (name "go-github-com-cespare-xxhash")
+ (name "go-github-com-cespare-xxhash-v2")
(version "2.1.2")
(source
(origin
@@ -373,7 +373,7 @@ the Ristretto prime-order group built from Edwards25519.")
(build-system go-build-system)
(arguments
(list
- #:import-path "github.com/cespare/xxhash"
+ #:import-path "github.com/cespare/xxhash/v2"
#:phases
#~(modify-phases %standard-phases
(replace 'check
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index f131499766..8324a2f568 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1237,7 +1237,7 @@ levels that works by wrapping the standard @code{log} library.")
(arguments
(list
#:import-path "github.com/coocood/freecache"))
- (propagated-inputs (list go-github-com-cespare-xxhash))
+ (propagated-inputs (list go-github-com-cespare-xxhash-v2))
(home-page "https://github.com/coocood/freecache")
(synopsis "Caching library for Go")
(description
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 64587ed3e1..c1c609cef9 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4750,7 +4750,7 @@ IPv6 Internet connectivity - it also works over IPv4.")
(list go-dario-cat-mergo
go-github-com-anmitsu-go-shlex
go-github-com-armon-go-radix
- go-github-com-cespare-xxhash
+ go-github-com-cespare-xxhash-v2
go-github-com-cyberdelia-go-metrics-graphite
go-github-com-flynn-noise
go-github-com-gogo-protobuf
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 7deea364d8..0b77a24d23 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1589,7 +1589,7 @@ files for valid UTF-8 use and to report which line endings they use.")
#:install-source? #f
#:import-path "github.com/aswinkarthik/csvdiff"))
(native-inputs
- (list go-github-com-cespare-xxhash
+ (list go-github-com-cespare-xxhash-v2
go-github-com-fatih-color
go-github-com-spf13-afero
go-github-com-spf13-cobra