aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-08-24 13:17:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-08-26 22:32:36 +0200
commitb0b9653c28276492de639c6cd1707023fc88014e (patch)
treebd81ff73e5a95b9980d1d4c4c07e40f6ff8e4201 /gnu
parent0f5fdd5e65343dff2e46bea2ed61afdbf651705a (diff)
downloadguix-b0b9653c28276492de639c6cd1707023fc88014e.tar
guix-b0b9653c28276492de639c6cd1707023fc88014e.tar.gz
gnu: Add emacs-plz-event-source.
* gnu/packages/emacs-xyz.scm (emacs-plz-event-source): New variable. Change-Id: I66fc237fb191c0406fcf2d08c2938264e2dd9b95 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 485ffeac59..6ac1d3496c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21513,6 +21513,30 @@ processing standard MIME types, including JSON, XML, HTML, and binary data, in
a streaming and non-streaming way.")
(license license:gpl3+)))
+(define-public emacs-plz-event-source
+ (package
+ (name "emacs-plz-event-source")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/r0man/plz-event-source")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rg3dmaqnhzvzqsyfnk3y77s88jrjpwpzkj1fyz40j8b184q3qcs"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-plz-media-type))
+ (arguments (list #:tests? #f))
+ (home-page "https://github.com/r0man/plz-event-source")
+ (synopsis "Server Sent Events extension for Plz")
+ (description
+ "The @code{plz-event-source} library provides a @code{plz-media-type},
+a parser, and an event source implementation for the @acronym{SSE, Server Sent
+Event} protocol.")
+ (license license:gpl3+)))
+
(define-public emacs-ement
(package
(name "emacs-ement")