aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-08-24 13:17:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-08-26 22:32:35 +0200
commit0f5fdd5e65343dff2e46bea2ed61afdbf651705a (patch)
tree76f9202d5f9fe94678f5016531f664a4b93bd2b9 /gnu
parent8fe362b69f91b718967accedf74dd447d372bf43 (diff)
downloadguix-0f5fdd5e65343dff2e46bea2ed61afdbf651705a.tar
guix-0f5fdd5e65343dff2e46bea2ed61afdbf651705a.tar.gz
gnu: Add emacs-plz-media-type.
* gnu/packages/emacs-xyz.scm (emacs-plz-media-type): New variable. Change-Id: Ib38d91e1cc642afd34b480967a34e0db0e28e4c6 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e1176ab202..485ffeac59 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21486,6 +21486,33 @@ multiplexer.")
which avoids some of the issues with using Emacs’s built-in Url library.")
(license license:gpl3+)))
+(define-public emacs-plz-media-type
+ (package
+ (name "emacs-plz-media-type")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/r0man/plz-media-type")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1bxrinp276rzz1jwnqrs5xginm96vzxr0b1k5q3y56lnin8sp18x"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-plz))
+ (arguments (list #:tests? #f))
+ (home-page "https://github.com/r0man/plz-media-type")
+ (synopsis "HTTP media type extension for plz.el")
+ (description
+ "The @code{plz-media-type} library enhances MIME type handling for HTTP
+requests within Emacs. It leverages the Plz HTTP library for networking calls
+and introduces a mechanism to process responses based on the content type
+header. This library defines various classes and methods for parsing and
+processing standard MIME types, including JSON, XML, HTML, and binary data, in
+a streaming and non-streaming way.")
+ (license license:gpl3+)))
+
(define-public emacs-ement
(package
(name "emacs-ement")