aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-22 22:46:44 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-22 22:47:22 +0100
commita72cef475e98e848d7c59c5e46f1bf7d540af817 (patch)
treed79bc2b5114c2618158df50555140c65c0ead1e3 /gnu
parent76adf5e3ca0f32c4369f1b61fc0cd32937384118 (diff)
downloadguix-a72cef475e98e848d7c59c5e46f1bf7d540af817.tar
guix-a72cef475e98e848d7c59c5e46f1bf7d540af817.tar.gz
gnu: go-github-com-syndtr-goleveldb: Disable some failing tests.
* gnu/packages/golang.scm (go-github-com-syndtr-goleveldb) [arguments]: <#:phases>: Add 'disable-failing-tests phase.d Change-Id: Id79eb1aa31e01e5b99d7f2edaa6935bf0f97ea46
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 9931911e32..00afcc1c88 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4576,6 +4576,13 @@ well as a program to generate applications and command files.")
#:import-path "github.com/syndtr/goleveldb"
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key tests? unpack-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" unpack-path)
+ (substitute* (find-files "." "\\_test.go$")
+ ;; XXX Failing on i686-linux:
+ ;; failed on input 0xde6d70588e18c85b, 0x85261e67
+ (("TestBatchHeader") "OffTestBatchHeader")))))
;; XXX: Replace when go-build-system supports nested path.
(delete 'build)
(replace 'check