aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 9931911e32..00afcc1c88 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4576,6 +4576,13 @@ well as a program to generate applications and command files.")
#:import-path "github.com/syndtr/goleveldb"
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key tests? unpack-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" unpack-path)
+ (substitute* (find-files "." "\\_test.go$")
+ ;; XXX Failing on i686-linux:
+ ;; failed on input 0xde6d70588e18c85b, 0x85261e67
+ (("TestBatchHeader") "OffTestBatchHeader")))))
;; XXX: Replace when go-build-system supports nested path.
(delete 'build)
(replace 'check