aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNiklas Eklund <niklas.eklund@posteo.net>2021-06-18 12:08:04 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-18 12:08:04 +0200
commit93db7fa739f3116a33ec0e61b1a237bda326089a (patch)
treeebfab8e36e9548cc27effa25c6b451e48697fc66 /gnu
parentd4b86bac974fe133af629f5de25955339173f9ab (diff)
downloadguix-93db7fa739f3116a33ec0e61b1a237bda326089a.tar
guix-93db7fa739f3116a33ec0e61b1a237bda326089a.tar.gz
gnu: Add xkb-switch.
* gnu/packages/xdisorg.scm (xkb-switch): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xdisorg.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 5f29ac9657..b8c7a35a36 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Renzo Poddighe <renzo@poddighe.nl>
;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2021 Niklas Eklund <niklas.eklund@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -359,6 +360,33 @@ high-level and flexible remapping mechanisms. It affects the low-level
layers (evdev and uinput), making remapping work in almost all the places.")
(license license:gpl3+))) ; see README.md (no licence headers)
+(define-public xkb-switch
+ (package
+ (name "xkb-switch")
+ (version "1.8.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/grwlf/xkb-switch")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1sd6ihgsswp6hjm1i4y092n4gl3gj0bc22grz4n7iy43mwphi40d"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ;no test target
+ (inputs
+ `(("libx11" ,libx11)
+ ("libxkbfile" ,libxkbfile)))
+ (home-page "https://github.com/grwlf/xkb-switch")
+ (synopsis "Switch your X keyboard layouts from the command line")
+ (description
+ "xkb-switch is a C++ program that queries and changes the XKB layout
+state.")
+ (license license:gpl3+)))
+
(define-public xclip
(package
(name "xclip")