aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 15:14:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:36 +0200
commit86556e6bb9fca81d26036cc5652e482678bee875 (patch)
treeda987ddbd0656830fef7ba3760ce02405db7cd95 /gnu
parent07eb98079ecc8d45cfb85bd4af922b5ccfbb0981 (diff)
downloadguix-86556e6bb9fca81d26036cc5652e482678bee875.tar
guix-86556e6bb9fca81d26036cc5652e482678bee875.tar.gz
gnu: Add texlive-showhyphenation.
* gnu/packages/tex.scm (texlive-showhyphenation): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 87ac4b0b6c..c831b3b9d1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13837,6 +13837,28 @@ predefined search patterns. The search patterns focus on ligatures deemed
inappropriate because they span morpheme boundaries.")
(license license:lppl1.3+)))
+(define-public texlive-showhyphenation
+ (package
+ (name "texlive-showhyphenation")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/showhyphenation/"
+ "tex/lualatex/showhyphenation/")
+ (base32
+ "0v8rjr828pzcn85zqbrw3fnrfyvn7cscqyg5mm08wyay990lkhny")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/showhyphenation")
+ (synopsis "Marking of hyphenation points")
+ (description
+ "The package shows the hyphenation points in the document by either
+inserting small triangles below the baseline or by typesetting explicit
+hyphens. The markers are correctly placed even within ligatures and their
+size adjusts to the font size. By option the markers can be placed behind or
+in front of the glyphs. The package requires LuaLaTeX.")
+ (license license:lppl1.3c)))
+
(define-public texlive-standalone
(package
(name "texlive-standalone")