aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-05 23:42:18 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:44:59 +0800
commit80b47c3b5ef7a3d8e84baae4e23d7b27bc0d02d0 (patch)
tree82e3ce6a441dcd49f5df08e4d60a5e975cd7eeec /gnu
parentc1eee27aae8be1625927c9a1a2169c9b87f8e695 (diff)
downloadguix-80b47c3b5ef7a3d8e84baae4e23d7b27bc0d02d0.tar
guix-80b47c3b5ef7a3d8e84baae4e23d7b27bc0d02d0.tar.gz
gnu: karchive: Update to 6.3.0.
* gnu/packages/kde-frameworks.scm (karchive): Update to 6.3.0. [inputs]: Remove qtbase-5; add qtbase. [native-inputs]: Remove qttools-5; add qttools. [synopsis]: Adjust it. Change-Id: I159efc5f824b2aac034b8f34cec0c1e339580591
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 1a92f642be..ec6935974e 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -459,7 +459,7 @@ documentation.")
(define-public karchive
(package
(name "karchive")
- (version "5.114.0")
+ (version "6.3.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/frameworks/"
@@ -467,7 +467,7 @@ documentation.")
"/" name "-" version ".tar.xz"))
(sha256
(base32
- "015gc1zarny8r478p7g9m6r67l5dk3r0vcp28ilmfmznxy0k0hda"))))
+ "0aafcxizxzh239sz9ffsgxbq6c4a368bm3l93jj9m3v60xbpz017"))))
(build-system cmake-build-system)
(arguments
(list #:phases #~(modify-phases %standard-phases
@@ -476,17 +476,16 @@ documentation.")
(when tests?
(invoke "ctest" "-E" "karchivetest")))))))
(native-inputs
- (list extra-cmake-modules pkg-config qttools-5))
- (inputs
- (list bzip2 qtbase-5 xz zlib `(,zstd "lib")))
- (home-page "https://community.kde.org/Frameworks")
- (synopsis "Qt 5 addon providing access to numerous types of archives")
+ (list extra-cmake-modules pkg-config qttools))
+ (inputs (list bzip2 qtbase xz zlib `(,zstd "lib")))
+ (synopsis "Qt 6 addon providing access to numerous types of archives")
(description
"KArchive provides classes for easy reading, creation and
manipulation of @code{archive} formats like ZIP and TAR.
It also provides transparent compression and decompression of data, like the
GZip format, via a subclass of QIODevice.")
+ (home-page "https://community.kde.org/Frameworks")
;; The included licenses is are gpl2 and lgpl2.1, but the sources are
;; under a variety of licenses.
;; This list is taken from http://packaging.neon.kde.org/cgit/