aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 1a92f642be..ec6935974e 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -459,7 +459,7 @@ documentation.")
(define-public karchive
(package
(name "karchive")
- (version "5.114.0")
+ (version "6.3.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/frameworks/"
@@ -467,7 +467,7 @@ documentation.")
"/" name "-" version ".tar.xz"))
(sha256
(base32
- "015gc1zarny8r478p7g9m6r67l5dk3r0vcp28ilmfmznxy0k0hda"))))
+ "0aafcxizxzh239sz9ffsgxbq6c4a368bm3l93jj9m3v60xbpz017"))))
(build-system cmake-build-system)
(arguments
(list #:phases #~(modify-phases %standard-phases
@@ -476,17 +476,16 @@ documentation.")
(when tests?
(invoke "ctest" "-E" "karchivetest")))))))
(native-inputs
- (list extra-cmake-modules pkg-config qttools-5))
- (inputs
- (list bzip2 qtbase-5 xz zlib `(,zstd "lib")))
- (home-page "https://community.kde.org/Frameworks")
- (synopsis "Qt 5 addon providing access to numerous types of archives")
+ (list extra-cmake-modules pkg-config qttools))
+ (inputs (list bzip2 qtbase xz zlib `(,zstd "lib")))
+ (synopsis "Qt 6 addon providing access to numerous types of archives")
(description
"KArchive provides classes for easy reading, creation and
manipulation of @code{archive} formats like ZIP and TAR.
It also provides transparent compression and decompression of data, like the
GZip format, via a subclass of QIODevice.")
+ (home-page "https://community.kde.org/Frameworks")
;; The included licenses is are gpl2 and lgpl2.1, but the sources are
;; under a variety of licenses.
;; This list is taken from http://packaging.neon.kde.org/cgit/