aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 15:30:16 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 15:30:49 +0100
commit673b48bf60830b8f4e4ed728b4f2d7afdb6ae52a (patch)
tree6f4c059549e28573b41a42aa5e8db93782de890b /gnu
parent47fc4850e42f4d1e4d76189431863124f7885576 (diff)
downloadguix-673b48bf60830b8f4e4ed728b4f2d7afdb6ae52a.tar
guix-673b48bf60830b8f4e4ed728b4f2d7afdb6ae52a.tar.gz
gnu: Add go-github-com-whyrusleeping-go-keyspace.
* gnu/packages/golang-xyz.scm (go-github-com-whyrusleeping-go-keyspace): New variable. Change-Id: I089ffd2ad61a998958d64465c14cbfe941fc30e9
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 56cf1d0287..7eb303063e 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4846,6 +4846,31 @@ encoded values to create the picture in a code with no inherent errors.")
weighted moving averages}.")
(license license:expat)))
+(define-public go-github-com-whyrusleeping-go-keyspace
+ (package
+ (name "go-github-com-whyrusleeping-go-keyspace")
+ (version "0.0.0-20160322163242-5b898ac5add1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/whyrusleeping/go-keyspace")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0fkk7i7qxwbz1g621mm6a6inb69lr57cyc9ayyfiwhnjwfz78rbb"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/whyrusleeping/go-keyspace"))
+ (home-page "https://github.com/whyrusleeping/go-keyspace")
+ (synopsis "Comparing key metrics within a given keyspace")
+ (description
+ "This is a package extracted from @code{go-ipfs}. Its purpose to be used
+to compare a set of keys based on a given metric. The primary metric used is
+XOR, as in kademlia.")
+ (license license:expat)))
+
(define-public go-github-com-whyrusleeping-go-sysinfo
(package
(name "go-github-com-whyrusleeping-go-sysinfo")